summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-14 14:16:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-18 14:09:07 +0200
commitb630f7dfa994ac8260ede67cc04e2a34e0f19588 (patch)
treed21e25a2671807bdc2dfa3671e22e2a9bac519c4 /dev-vcs/git/git-9999.ebuild
parentapp-text/evince: Rename USE=gnome-keyring -> keyring (diff)
downloadgentoo-b630f7dfa994ac8260ede67cc04e2a34e0f19588.tar.gz
gentoo-b630f7dfa994ac8260ede67cc04e2a34e0f19588.tar.bz2
gentoo-b630f7dfa994ac8260ede67cc04e2a34e0f19588.zip
dev-vcs/git: Rename USE=gnome-keyring -> keyring
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index ce146cc61342..867bbd70fc71 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -58,7 +58,7 @@ S="${WORKDIR}"/${MY_P}
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc gnome-keyring +gpg highlight +iconv mediawiki +nls +pcre perforce +perl +safe-directory selinux subversion tk +webdav xinetd cvs test"
+IUSE="+blksha1 +curl cgi doc keyring +gpg highlight +iconv mediawiki +nls +pcre perforce +perl +safe-directory selinux subversion tk +webdav xinetd cvs test"
# Common to both DEPEND and RDEPEND
DEPEND="
@@ -68,7 +68,7 @@ DEPEND="
net-misc/curl
webdav? ( dev-libs/expat )
)
- gnome-keyring? (
+ keyring? (
app-crypt/libsecret
dev-libs/glib:2
)
@@ -120,7 +120,7 @@ BDEPEND="
app-text/xmlto
sys-apps/texinfo
)
- gnome-keyring? ( virtual/pkgconfig )
+ keyring? ( virtual/pkgconfig )
nls? ( sys-devel/gettext )
test? ( app-crypt/gnupg )
"
@@ -343,7 +343,7 @@ src_compile() {
fi
popd &>/dev/null || die
- if use gnome-keyring ; then
+ if use keyring ; then
git_emake -C contrib/credential/libsecret
fi
@@ -543,7 +543,7 @@ src_install() {
doexe contrib/contacts/git-contacts
dodoc contrib/contacts/git-contacts.txt
- if use gnome-keyring ; then
+ if use keyring ; then
pushd contrib/credential/libsecret &>/dev/null || die
dobin git-credential-libsecret
popd &>/dev/null || die