summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/gitolite-gentoo/gitolite-gentoo-2.3.3-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/gitolite-gentoo/gitolite-gentoo-2.3.3-r1.ebuild')
-rw-r--r--dev-vcs/gitolite-gentoo/gitolite-gentoo-2.3.3-r1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-vcs/gitolite-gentoo/gitolite-gentoo-2.3.3-r1.ebuild b/dev-vcs/gitolite-gentoo/gitolite-gentoo-2.3.3-r1.ebuild
new file mode 100644
index 000000000000..f89dc8f39b81
--- /dev/null
+++ b/dev-vcs/gitolite-gentoo/gitolite-gentoo-2.3.3-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils perl-module user
+
+DESCRIPTION="Highly flexible server for git directory version tracker, Gentoo fork"
+HOMEPAGE="http://cgit.gentoo.org/proj/gitolite-gentoo.git"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="contrib vim-syntax"
+
+DEPEND="dev-lang/perl
+ virtual/perl-File-Path
+ virtual/perl-File-Temp
+ >=dev-vcs/git-1.6.6"
+RDEPEND="${DEPEND}
+ !dev-vcs/gitolite
+ dev-perl/Net-SSH-AuthorizedKeysFile
+ vim-syntax? ( app-vim/gitolite-syntax )"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/bash /var/lib/gitolite git
+}
+
+src_prepare() {
+ rm Makefile doc/COPYING || die
+ rm -rf contrib/{gitweb,vim} || die
+
+ echo "${PF}-gentoo" > conf/VERSION
+}
+
+src_install() {
+ local gl_bin="${D}/usr/bin"
+ gl_bin=${gl_bin/\/\//\/}
+
+ dodir /usr/share/gitolite/{conf,hooks} /usr/bin || die
+
+ export PATH="${gl_bin}:${PATH}"
+ ./src/gl-system-install ${gl_bin} \
+ "${D}"/usr/share/gitolite/conf "${D}"/usr/share/gitolite/hooks || die
+ sed -i -e "s:${D}::g" "${D}/usr/bin/gl-setup" \
+ "${D}/usr/share/gitolite/conf/example.gitolite.rc" || die
+
+ rm "${D}"/usr/bin/*.pm
+ insinto "${VENDOR_LIB}"
+ doins src/*.pm || die
+
+ dodoc README.mkd doc/*
+
+ if use contrib; then
+ insinto /usr/share/doc/${PF}
+ doins -r contrib/ || die
+ fi
+
+ keepdir /var/lib/gitolite
+ fowners git:git /var/lib/gitolite
+ fperms 750 /var/lib/gitolite
+}
+
+pkg_postinst() {
+ # bug 352291
+ ewarn
+ elog "Please make sure that your 'git' user has the correct homedir (/var/lib/gitolite)."
+ elog "Especially if you're migrating from gitosis."
+ ewarn
+ ewarn
+ elog "If you use the umask feature and upgrade from <=gitolite-gentoo-1.5.9.1"
+ elog "then please check the permissions of all repositories using the umask feature"
+ ewarn
+}