summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-08-27 20:20:12 -0600
committerChristoph Junghans <ottxor@gentoo.org>2015-08-27 20:23:23 -0600
commit946f0ad99537140416114728e4d8b25304cc65e9 (patch)
tree7489e23ad331eaf6caa5fb56e88b98faa1faaedb /dev-vcs/hg-fast-export/hg-fast-export-20150816.ebuild
parentapp-editors/gummi: Bump EAPI, move upstream repository to git (diff)
downloadgentoo-946f0ad99537140416114728e4d8b25304cc65e9.tar.gz
gentoo-946f0ad99537140416114728e4d8b25304cc65e9.tar.bz2
gentoo-946f0ad99537140416114728e4d8b25304cc65e9.zip
dev-vcs/hg-fast-export: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-vcs/hg-fast-export/hg-fast-export-20150816.ebuild')
-rw-r--r--dev-vcs/hg-fast-export/hg-fast-export-20150816.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-vcs/hg-fast-export/hg-fast-export-20150816.ebuild b/dev-vcs/hg-fast-export/hg-fast-export-20150816.ebuild
new file mode 100644
index 000000000000..1d91066e0057
--- /dev/null
+++ b/dev-vcs/hg-fast-export/hg-fast-export-20150816.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 vcs-snapshot
+
+COMMIT="3c27c693e13482059966003dd6545941b942a97a"
+DESCRIPTION="mercurial to git converter using git-fast-import"
+HOMEPAGE="https://github.com/frej/fast-export"
+SRC_URI="${HOMEPAGE}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/git
+ dev-vcs/mercurial
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ sed -e '/^PYTHON/s/python/&2.7/' \
+ -e '/^PYTHON/s/PYTHON:/E&/g' \
+ -e "/^ROOT/s:=.*:='${EPREFIX}/usr/bin':" \
+ -i "${PN}".sh || die
+ rm Makefile || die #don't compile old svn2git code
+}
+
+src_install() {
+ newbin "${PN}".sh "${PN}"
+ dodoc README
+ python_foreach_impl python_doexe "${PN}".py
+ python_foreach_impl python_domodule hg2git.py
+}