summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2016-02-20 11:46:39 +0100
committerDirkjan Ochtman <djc@gentoo.org>2016-02-20 11:46:39 +0100
commit74734d9593b4bac057ee4c254ec7b279417e5fca (patch)
treece0664e0c76bfe09eee273998fe81dac3ccb4bc7 /dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild
parentdev-vcs/hg-git: version bump to 0.8.5 (diff)
downloadgentoo-74734d9593b4bac057ee4c254ec7b279417e5fca.tar.gz
gentoo-74734d9593b4bac057ee4c254ec7b279417e5fca.tar.bz2
gentoo-74734d9593b4bac057ee4c254ec7b279417e5fca.zip
dev-vcs/hgsubversion: version bump to 1.8.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild')
-rw-r--r--dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild b/dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild
new file mode 100644
index 000000000000..4b4ce127570a
--- /dev/null
+++ b/dev-vcs/hgsubversion/hgsubversion-1.8.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="hgsubversion is a Mercurial extension for working with Subversion repositories"
+HOMEPAGE="https://bitbucket.org/durin42/hgsubversion/wiki/Home https://pypi.python.org/pypi/hgsubversion"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+
+# although any ref absent in the source, tests fail badly with >=mercurial-2.8.1
+RDEPEND=">=dev-vcs/mercurial-1.4[${PYTHON_USEDEP}]
+ dev-vcs/mercurial[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/subvertpy-0.7.4[${PYTHON_USEDEP}]
+ >=dev-vcs/subversion-1.5[python] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DOCS=( README )
+
+#python_test() {
+# "${PYTHON}" tests/run.py || die "Tests failed under ${EPYTHON}"
+#}