summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-01-23 11:53:53 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-01-24 03:46:10 +1100
commit325972580af126dd19d05a3573167cefe20a3cd2 (patch)
tree3dce98d8273f1a9832f83fed693a2ad2914a3035 /dev-vcs/kdesvn/kdesvn-1.7.0.ebuild
parentsys-block/partitionmanager: Version bump to 2.0.0 (diff)
downloadgentoo-325972580af126dd19d05a3573167cefe20a3cd2.tar.gz
gentoo-325972580af126dd19d05a3573167cefe20a3cd2.tar.bz2
gentoo-325972580af126dd19d05a3573167cefe20a3cd2.zip
dev-vcs/kdesvn: Version bump to 1.7.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-vcs/kdesvn/kdesvn-1.7.0.ebuild')
-rw-r--r--dev-vcs/kdesvn/kdesvn-1.7.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-vcs/kdesvn/kdesvn-1.7.0.ebuild b/dev-vcs/kdesvn/kdesvn-1.7.0.ebuild
new file mode 100644
index 000000000000..4804b7b0db1d
--- /dev/null
+++ b/dev-vcs/kdesvn/kdesvn-1.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="cs de el es fr it ja lt pt_BR ro ru"
+KDE_LINGUAS_LIVE_OVERRIDE="true"
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="A frontend to the subversion vcs"
+HOMEPAGE="http://kdesvn.alwins-world.de/"
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/apr:1
+ dev-libs/apr-util:1
+ dev-qt/qtsql:4[sqlite]
+ >=dev-vcs/subversion-1.7
+ sys-devel/gettext
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdesdk-kioslaves:4[subversion(+)]
+"
+
+src_configure() {
+ append-cppflags -DQT_THREAD_SUPPORT
+
+ [[ ${PV} = 9999* ]] && local mycmakeargs=(-DDAILY_BUILD=ON)
+
+ kde4-base_src_configure
+}