summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-04-15 11:40:25 +0200
committerFabian Groffen <grobian@gentoo.org>2019-04-15 11:40:36 +0200
commit60ae26372c5dbb24dd9d22246eb78713483c1865 (patch)
tree23945bd3e462bb6a0fffe6e0dad15e0459bdfd39 /dev-vcs/mercurial/mercurial-9999.ebuild
parentsys-kernel/git-sources: Automated version bump to 5.1_rc5. (diff)
downloadgentoo-60ae26372c5dbb24dd9d22246eb78713483c1865.tar.gz
gentoo-60ae26372c5dbb24dd9d22246eb78713483c1865.tar.bz2
gentoo-60ae26372c5dbb24dd9d22246eb78713483c1865.zip
dev-vcs/mercurial: make chg optional behind USE=chg (use-default)
chg client fails to compile on at least Solaris, so allow disabling this non-essential contrib addition. revbump from -r1 with stable keywords per maintainer's request. Closes: https://bugs.gentoo.org/683374 Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11 RepoMan-Options: --force
Diffstat (limited to 'dev-vcs/mercurial/mercurial-9999.ebuild')
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index 797fc104685b..39b4c67502eb 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -16,7 +16,7 @@ EHG_REVISION="@"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
-IUSE="bugzilla emacs gpg test tk zsh-completion"
+IUSE="+chg bugzilla emacs gpg test tk zsh-completion"
RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
gpg? ( app-crypt/gnupg )
@@ -52,6 +52,9 @@ python_configure_all() {
python_compile_all() {
rm -r contrib/{win32,macosx} || die
emake doc
+ if use chg; then
+ emake -C contrib/chg
+ fi
if use emacs; then
cd contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
@@ -83,6 +86,13 @@ python_install_all() {
local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
*.el mercurial.spec)
+
+ if use chg; then
+ dobin contrib/chg/chg
+ doman contrib/chg/chg.1
+ RM_CONTRIB+=( chg )
+ fi
+
for f in ${RM_CONTRIB[@]}; do
rm -rf contrib/$f || die
done