summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-03-15 09:28:00 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-03-15 09:28:22 +0000
commitb55991445032636c59c63aab64642dab4957a2af (patch)
tree3c30e000bf76b03b7bdc46ba4b20362d07f508a0 /dev-vcs/mercurial/mercurial-9999.ebuild
parentdev-ruby/pluggaloid: cleanup (diff)
downloadgentoo-b55991445032636c59c63aab64642dab4957a2af.tar.gz
gentoo-b55991445032636c59c63aab64642dab4957a2af.tar.bz2
gentoo-b55991445032636c59c63aab64642dab4957a2af.zip
dev-vcs/mercurial: drop 'strip-flags' parameters, bug #712594
This is not a fix for bug #712594. The code change only gets ebuild to the state it was before f8669c1089dd9962d946c7be46 "flag-o-matic.eclass: add assertions around argument counts" was submitted. We'll need a proper fix. I've left a TODO in ebuild. Bug: https://bugs.gentoo.org/712594 Package-Manager: Portage-2.3.94, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-vcs/mercurial/mercurial-9999.ebuild')
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index 8c12d545eb87..8a93eddd65bf 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -57,7 +57,7 @@ python_prepare_all() {
}
python_compile() {
- strip-flags -ftracer -ftree-vectorize
+ strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile build_ext --no-zstd
}