summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/qct
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/qct')
-rw-r--r--dev-vcs/qct/Manifest1
-rw-r--r--dev-vcs/qct/files/qct.rc3
-rw-r--r--dev-vcs/qct/metadata.xml16
-rw-r--r--dev-vcs/qct/qct-1.7-r1.ebuild72
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-vcs/qct/Manifest b/dev-vcs/qct/Manifest
new file mode 100644
index 000000000000..4e43d88d2c40
--- /dev/null
+++ b/dev-vcs/qct/Manifest
@@ -0,0 +1 @@
+DIST qct-1.7.tar.gz 56658 SHA256 06e9969f6c8a08b67f289bc0e95b4f4469d6adbf1aa0bed0f0cc8c5bdea222d0 SHA512 85f8b6bcd5c4081ba17da1bc7e17d0036ec10d9133ed5383adbca16f81b8550d6f137e34636c20f3d03b7cedca75467daa057022374866b4e2ab18aaf7d4b6d2 WHIRLPOOL 1b806fdf090e8465e0c36e5ce6d6879d9cdc43f8906b1a13c72c6f1806c40fff6a1a77b0db59a60b9566e4ac785192a8ab498103bef249ee560899b0c05b0e2a
diff --git a/dev-vcs/qct/files/qct.rc b/dev-vcs/qct/files/qct.rc
new file mode 100644
index 000000000000..3ab69befa3c5
--- /dev/null
+++ b/dev-vcs/qct/files/qct.rc
@@ -0,0 +1,3 @@
+[extensions]
+hgext.qct=
+
diff --git a/dev-vcs/qct/metadata.xml b/dev-vcs/qct/metadata.xml
new file mode 100644
index 000000000000..481f5eadf4ab
--- /dev/null
+++ b/dev-vcs/qct/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <use>
+ <flag name='bazaar'>
+ Support for <pkg>dev-vcs/bzr</pkg>
+ </flag>
+ <flag name='mercurial'>
+ Support for <pkg>dev-vcs/mercurial</pkg>
+ </flag>
+ <flag name='monotone'>
+ Support for <pkg>dev-vcs/monotone</pkg>
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-vcs/qct/qct-1.7-r1.ebuild b/dev-vcs/qct/qct-1.7-r1.ebuild
new file mode 100644
index 000000000000..5fdc37fa8be4
--- /dev/null
+++ b/dev-vcs/qct/qct-1.7-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="PyQt based commit tool for many VCSs"
+HOMEPAGE="http://qct.sourceforge.net/"
+SRC_URI="http://qct.sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bazaar cvs mercurial monotone subversion"
+
+DEPEND="app-text/asciidoc[${PYTHON_USEDEP}]
+ app-text/xmlto
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ bazaar? ( dev-vcs/bzr[${PYTHON_USEDEP}] )
+ cvs? ( dev-vcs/cvs )
+ mercurial? ( dev-vcs/mercurial[${PYTHON_USEDEP}] )
+ monotone? ( dev-vcs/monotone )
+ subversion? ( dev-vcs/subversion[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ rm qctlib/vcs/p4.py
+
+ # support for git requires cogito which isn't in portage
+ rm qctlib/vcs/git.py
+ rm qctlib/vcs/cg.py
+
+ use bazaar || rm qctlib/vcs/bzr.py
+ use cvs || rm qctlib/vcs/cvs.py
+ use mercurial || rm qctlib/vcs/hg.py
+ use monotone || rm qctlib/vcs/mtn.py
+ use subversion || rm qctlib/vcs/svn.py
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # manpage and html docs are built using asciidoc
+ make -C doc man html || die
+ doman doc/qct.1 || die
+ dohtml doc/qct.1.html || die
+
+ if use bazaar; then
+ insinto "$(python_get_sitedir)/bzrlib/plugins"
+ doins plugins/qctBzrPlugin.py
+ fi
+
+ if use mercurial; then
+ insinto "$(python_get_sitedir)/hgext"
+ doins hgext/qct.py
+ insinto /etc/mercurial/hgrc.d
+ doins "${FILESDIR}/qct.rc"
+ fi
+}