summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/rcsi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/rcsi')
-rw-r--r--dev-vcs/rcsi/Manifest1
-rw-r--r--dev-vcs/rcsi/metadata.xml8
-rw-r--r--dev-vcs/rcsi/rcsi-0.5.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-vcs/rcsi/Manifest b/dev-vcs/rcsi/Manifest
new file mode 100644
index 000000000000..e04218b3e50f
--- /dev/null
+++ b/dev-vcs/rcsi/Manifest
@@ -0,0 +1 @@
+DIST rcsi-0.5.tar.gz 68705 SHA256 b7b398addd2a329b1e737b21030e533c24611f1052d09135fddac6afbcd491b1 SHA512 4b9cf2bc9232fdad45461de1f2eca06958a26f2cfd1bb823be465102a152f31405aa611da922be5ebd9c83ff6efa62784fe9954563dee980befe1acd9c032f72 WHIRLPOOL 85be746f9fafd15e6d9d31afbdb7d7666786ee949c010e28586b891af30e156fa8620d42d579d4123259b8d5a295c0c6770071802379e14df07d1bd84816b622
diff --git a/dev-vcs/rcsi/metadata.xml b/dev-vcs/rcsi/metadata.xml
new file mode 100644
index 000000000000..cb2f040031cf
--- /dev/null
+++ b/dev-vcs/rcsi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cvs-utils</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-vcs/rcsi/rcsi-0.5.ebuild b/dev-vcs/rcsi/rcsi-0.5.ebuild
new file mode 100644
index 000000000000..bdef2a7fd17e
--- /dev/null
+++ b/dev-vcs/rcsi/rcsi-0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="A program to give information about RCS files"
+HOMEPAGE="http://www.colinbrough.pwp.blueyonder.co.uk/rcsi.README.html"
+SRC_URI="http://www.colinbrough.pwp.blueyonder.co.uk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND=">=dev-vcs/rcs-5.7-r2"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ $(tc-getCC) $CFLAGS $LDFLAGS rcsi.c -o rcsi || die "Compile failed"
+}
+
+src_install() {
+ dobin rcsi
+ doman rcsi.1
+ dodoc README
+ dohtml README.html example{1,2}.png
+}