summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/statcvs/statcvs-0.5.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/statcvs/statcvs-0.5.0.ebuild')
-rw-r--r--dev-vcs/statcvs/statcvs-0.5.0.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-vcs/statcvs/statcvs-0.5.0.ebuild b/dev-vcs/statcvs/statcvs-0.5.0.ebuild
new file mode 100644
index 000000000000..7afecc0a116c
--- /dev/null
+++ b/dev-vcs/statcvs/statcvs-0.5.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="doc source test"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="StatCVS generates HTML reports from CVS repository logs"
+HOMEPAGE="http://statcvs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-source.zip"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-java/jcommon:1.0
+ >=dev-java/jfreechart-1.0.11:1.0
+ dev-java/jdom:1.0
+ dev-java/ant-core:0"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ test? ( dev-java/ant-junit:0 )
+ ${COMMON_DEPEND}"
+
+RDEPEND=">=virtual/jre-1.4
+ dev-vcs/cvs
+ dev-java/jtreemap:0
+ ${COMMON_DEPEND}"
+
+EANT_BUILD_TARGET="compile copyfiles jar"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${P}-build.xml.patch
+ epatch "${FILESDIR}"/${PN}-0.4.0-external-jtreemap.patch
+
+ einfo "Removing bundled jars."
+ find . -name "*.jar" -print -delete
+
+ cd "${S}"/lib || die
+ java-pkg_jar-from jcommon-1.0 jcommon.jar jcommon-1.0.6.jar
+ java-pkg_jar-from jfreechart-1.0 jfreechart.jar jfreechart-1.0.3.jar
+ java-pkg_jar-from jdom-1.0 jdom.jar
+ java-pkg_jar-from ant-core ant.jar
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ java-pkg_dolauncher ${PN} --main net.sf.statcvs.Main
+
+ use doc && java-pkg_dohtml -r doc/*
+ use source && java-pkg_dosrc src/net
+}
+
+src_test() {
+ java-pkg_jar-from --into lib junit
+ ANT_TASKS="ant-junit" eant test
+}
+
+pkg_postinst() {
+ elog "For instructions on how to use StatCVS see"
+ elog "http://statcvs.sourceforge.net/manual/"
+ elog "You need to regenerate statistics"
+ elog "if you update dev-java/jtreemap"
+}