summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHank Leininger <hlein@korelogic.com>2019-11-19 23:39:58 -0700
committerJoonas Niilola <juippis@gentoo.org>2019-12-02 08:24:19 +0200
commit3d503016e9a823a397c70b044b1910fd174ee2bf (patch)
tree40ea4e0b9eb5f947e11021461b8f7e171bdda4a9 /dev-vcs/svn2cl/svn2cl-0.14.ebuild
parentx11-misc/redshift: drop old (diff)
downloadgentoo-3d503016e9a823a397c70b044b1910fd174ee2bf.tar.gz
gentoo-3d503016e9a823a397c70b044b1910fd174ee2bf.tar.bz2
gentoo-3d503016e9a823a397c70b044b1910fd174ee2bf.zip
dev-vcs/svn2cl: Version bump, add myself as proxy maintainer.
Redone after the initial version in https://github.com/gentoo/gentoo/pull/13458 became mostly obsolete. Signed-off-by: Hank Leininger <hlein@korelogic.com> Closes: https://bugs.gentoo.org/698602 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Closes: https://github.com/gentoo/gentoo/pull/13717 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs/svn2cl/svn2cl-0.14.ebuild')
-rw-r--r--dev-vcs/svn2cl/svn2cl-0.14.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-vcs/svn2cl/svn2cl-0.14.ebuild b/dev-vcs/svn2cl/svn2cl-0.14.ebuild
new file mode 100644
index 000000000000..e9516274cee7
--- /dev/null
+++ b/dev-vcs/svn2cl/svn2cl-0.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Create a GNU-style ChangeLog from subversion's svn log --xml output"
+HOMEPAGE="https://arthurdejong.org/svn2cl/"
+SRC_URI="https://arthurdejong.org/svn2cl/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+
+RDEPEND="dev-libs/libxslt
+ dev-vcs/subversion"
+
+PATCHES=( "${FILESDIR}/0.9-wrapper.patch" )
+
+src_install() {
+ newbin svn2cl.sh svn2cl
+ insinto /usr/share/svn2cl
+ doins svn2cl.xsl svn2html.xsl
+ dodoc README NEWS TODO ChangeLog authors.xml svn2html.css
+ doman svn2cl.1
+}
+
+pkg_postinst() {
+ elog "You can find samples of svn2html.css and authors.xml in"
+ elog "/usr/share/doc/${PF}/"
+ elog "Read man page for details."
+}