summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-09-01 17:29:37 +0200
committerSebastian Pipping <sping@gentoo.org>2018-09-01 17:29:37 +0200
commitd133c42f5b91592c1a53095223daf8dbfcb10e51 (patch)
tree79e05bdfd7c93b0a9e573dc80603ea08c81e39c5 /dev-vcs/svn2git/svn2git-1.0.13.ebuild
parentdev-libs/apr: skip testlfs test (diff)
downloadgentoo-d133c42f5b91592c1a53095223daf8dbfcb10e51.tar.gz
gentoo-d133c42f5b91592c1a53095223daf8dbfcb10e51.tar.bz2
gentoo-d133c42f5b91592c1a53095223daf8dbfcb10e51.zip
dev-vcs/svn2git: 1.0.13
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'dev-vcs/svn2git/svn2git-1.0.13.ebuild')
-rw-r--r--dev-vcs/svn2git/svn2git-1.0.13.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-vcs/svn2git/svn2git-1.0.13.ebuild b/dev-vcs/svn2git/svn2git-1.0.13.ebuild
new file mode 100644
index 000000000000..ab7c62035ef9
--- /dev/null
+++ b/dev-vcs/svn2git/svn2git-1.0.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop qmake-utils
+[[ "${PV}" == "9999" ]] && inherit git-r3
+
+DESCRIPTION="Tool for one-time conversion from svn to git"
+HOMEPAGE="https://github.com/svn-all-fast-export/svn2git"
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/svn-all-fast-export/svn2git.git"
+else
+ SRC_URI="https://github.com/svn-all-fast-export/svn2git/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# KEYWORDS way up
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-vcs/subversion"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+DOCS=( README.md )
+
+src_configure() {
+ local qmake_args=(
+ APR_INCLUDE=/usr/include/apr-1
+ PREFIX=/usr
+ SVN_INCLUDE=/usr/include/subversion-1
+ VERSION=${PV}
+ )
+ eqmake5 "${qmake_args[@]}" fast-export2.pro
+}
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/${PN}/samples
+ doins samples/*.rules || die 'doins failed'
+ dobin svn-all-fast-export || die 'dobin failed'
+ dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
+}