summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-10-22 11:18:15 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-10-22 11:18:15 +0200
commit721bb2106020c539b48ff2eab9d3e44dc3748e83 (patch)
tree352cd3bb0bb77b467e18a46ffb74dad159855f7d /dev-vcs/tortoisehg/tortoisehg-4.7.2.ebuild
parentsys-apps/file: Bump to version 5.35 (diff)
downloadgentoo-721bb2106020c539b48ff2eab9d3e44dc3748e83.tar.gz
gentoo-721bb2106020c539b48ff2eab9d3e44dc3748e83.tar.bz2
gentoo-721bb2106020c539b48ff2eab9d3e44dc3748e83.zip
dev-vcs/tortoisehg: Bump to version 4.7.2
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-vcs/tortoisehg/tortoisehg-4.7.2.ebuild')
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-4.7.2.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-vcs/tortoisehg/tortoisehg-4.7.2.ebuild b/dev-vcs/tortoisehg/tortoisehg-4.7.2.ebuild
new file mode 100644
index 000000000000..226c31c22223
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-4.7.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop distutils-r1
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-4.6 <dev-vcs/mercurial-4.8"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND="dev-vcs/mercurial"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+# Workaround race condition in build_qt
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ if [[ ${L10N+set} ]]; then
+ cd i18n/tortoisehg || die
+ local x y keep
+ for x in *.po; do
+ keep=false
+ for y in ${L10N}; do
+ if [[ ${y} == ${x%.po}* ]]; then
+ keep=true
+ break
+ fi
+ done
+ ${keep} || rm "${x}" || die
+ done
+ cd "${S}" || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ if use doc ; then
+ dohtml -r doc/build/html/
+ fi
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${ED%/}"/usr/$(get_libdir)/${EPYTHON}/site-packages/hgext3rd/__init__.py \
+ || die
+}
+
+pkg_postinst() {
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+ elog "dev-python/qscintilla-python."
+}