summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Gysel <me@bearsh.org>2024-01-27 14:27:31 +0100
committerYixun Lan <dlan@gentoo.org>2024-01-28 10:21:44 +0000
commit071e77401276c1b094a40e6bb8b6ee4d2fc76eb8 (patch)
treefecc2b2a9e575971bdf2774612996ec0438f33fe /dev-vcs
parentmail-client/claws-mail: depend on gtk+ with USE=X (diff)
downloadgentoo-071e77401276c1b094a40e6bb8b6ee4d2fc76eb8.tar.gz
gentoo-071e77401276c1b094a40e6bb8b6ee4d2fc76eb8.tar.bz2
gentoo-071e77401276c1b094a40e6bb8b6ee4d2fc76eb8.zip
dev-vcs/git-cola: add 4.5.0
Closes: https://bugs.gentoo.org/923027 Closes: https://github.com/gentoo/gentoo/pull/35043 Signed-off-by: Martin Gysel <me@bearsh.org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/Manifest1
-rw-r--r--dev-vcs/git-cola/git-cola-4.5.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-vcs/git-cola/Manifest b/dev-vcs/git-cola/Manifest
index 07c8df143593..21d6ba773b12 100644
--- a/dev-vcs/git-cola/Manifest
+++ b/dev-vcs/git-cola/Manifest
@@ -1,3 +1,4 @@
DIST git-cola-4.1.0.tar.gz 1140393 BLAKE2B 3236e06f86d23a7311e3cd639cbf2adcecb18810abcae938d1ff7cf25b477d814e614fffa20ce39dd9a2c6ab4f8e6b6b67f3ad3144163abe6530ac227313ca98 SHA512 4d2617947d4dbf3273f02c072de5ede10a656981f3653273780e2c1b1d3d613cd359fbb93cfb0a1d5de24b0c90818503cd9041ad3fa1a05b2ecd2db305bbe1a0
DIST git-cola-4.2.1.tar.gz 1191680 BLAKE2B 8dd9d4b52672e32deba2f54e7f9141d3364dcbf3a823b05e766f333063a26cc49ea9e5e2f43f9492447b6b7344c930a2a1160653fb2699ff7d23cb22783f4cd1 SHA512 1a9d63c985d3566f81edd3ed3debc4d499fa5147650d479f3b1bc833d08836a17d63a8eb23c1cd5c2c31f6f7202219fb77cacb628df8f85dd3d367dcdd110891
DIST git-cola-4.4.1.tar.gz 1212338 BLAKE2B 8f95720fa8af0acdecf744f657808b969f914bfd1cb2ccd2ed3af35f2811ab8aca7022ba888e0fc447a685af4c7dba27a0f0305f0b2d07cc31ccd22953d4fa14 SHA512 3e4e1cb8cd148b34e663c72c6b3d1e887815b5a86558ffbf13a19a5dfd3fb6b37c123290dc514b6f098893587dc67ca34424aaad5482768795e353f0efe92797
+DIST git-cola-4.5.0.tar.gz 1233372 BLAKE2B da9bbe2d1e49b5ebc49ae6ddecf72a73b4b262de2de6c5a9ef77d9946a338bb393154e91e8431dc11fc08f72e3fcfd19d424d68c2b846d05c0a87393f8cc33ac SHA512 99a17bf0398dc3049417b6af6f3fc3bc20682186859879c6fc3d2b8f9a8b3599612c555b40f76dd226323cefab0dec0b4424a566dc74637449743f675cb56817
diff --git a/dev-vcs/git-cola/git-cola-4.5.0.ebuild b/dev-vcs/git-cola/git-cola-4.5.0.ebuild
new file mode 100644
index 000000000000..198112123abf
--- /dev/null
+++ b/dev-vcs/git-cola/git-cola-4.5.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="The highly caffeinated git GUI"
+HOMEPAGE="https://git-cola.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets]
+ dev-python/QtPy[gui,network,${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ ')
+ dev-vcs/git
+"
+BDEPEND="
+ sys-devel/gettext
+ $(python_gen_cond_dep "
+ dev-python/setuptools-scm[\${PYTHON_USEDEP}]
+ test? (
+ ${VIRTUALX_DEPEND}
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ dev-python/PyQt5[\${PYTHON_USEDEP},gui,widgets]
+ )
+ ")
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/rst-linker'
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i "s|doc/git-cola =|doc/${PF} =|" setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ cd "${T}" || die
+ GIT_CONFIG_NOSYSTEM=true LC_ALL="C.utf8" \
+ epytest "${S}"/test
+}
+
+src_compile() {
+ SETUPTOOLS_SCM_PRETEND_VERSION=${PV} distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}