summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2020-05-19 15:41:36 -0400
committerMike Frysinger <vapier@gentoo.org>2020-05-19 15:42:24 -0400
commit07baa7ee856c6e77310fdacc6926ec63162fd832 (patch)
tree3cbf364ad481bb60c4d3c58c7528fbc5c1a30db6 /dev-vcs
parentdev-vcs/repo: mark 1.27 & 2.4 stable for most (diff)
downloadgentoo-07baa7ee856c6e77310fdacc6926ec63162fd832.tar.gz
gentoo-07baa7ee856c6e77310fdacc6926ec63162fd832.tar.bz2
gentoo-07baa7ee856c6e77310fdacc6926ec63162fd832.zip
dev-vcs/repo: version bump to 2.5
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/repo/Manifest1
-rw-r--r--dev-vcs/repo/repo-2.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index 29131724cf42..d6b342fbe452 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1,3 +1,4 @@
DIST repo-1.26 29829 BLAKE2B c5dc74214d404e6c11189a3d34c9a771ed5689da14e64588b5db144b6ea3ec38a727238d7dc6e609a22edb5b84d350210564615016f6b36599cf9e3fc3b34ef9 SHA512 1398fab95b4fb4a24fda93d4054384a801b5b70e3dca3a794f458d8e19582ef833ef5a3a0f3a571121d2d9172ce0e70f8b3c6719f6c2f47643ffe6de181e34b4
DIST repo-1.27 29945 BLAKE2B 930fa876b8889d64c8d12444f4cd59bebbdf9848d455e114fc9306922d931aa721320db65a07c38f705c39950538a1d5ae5ca66e359d2f2e38061d144ac11cb2 SHA512 a9f651e5fd1da1c74b31aebf32d03cf868183fa529eaf2b079015f9e778a2bb7c1ef49e06564703534c45fa1bd7bc5bd3d91a91477c336e549c1208afa74ace6
DIST repo-2.4 35152 BLAKE2B a069c095524574ee4a7d18cc5cd023f6d71b9ed9b57941180a6ec3ab3c33b2ed18b5dfc7d225a7bc849b7ebfd28bc0e672f7796eb2bb37af0685539c850cfe34 SHA512 46d7b8f699246ad625d5eb714791c29b949c40793343ba56681554040dc1d6a0a5f049e8d96f1e12ca93d77291e95ffd756f76554ebc1062f9cf6fc014aa116a
+DIST repo-2.5 38761 BLAKE2B 26d002bb7e5a24dc958bb4e0653c2cc260b2766d81fd55edf9a0373542365ed89a224805293383e2c16d8fc331038b265d3b2aca3a9a637d893f4a9c8221ce76 SHA512 36e515241fd9705c63beaf662309dc2ab6406552ba845fe020c878ac82e7eb7e1cd73924a076cf5fe4800ea70919bb5ad5d2d43566d5b0a559f81a45f9a58fe8
diff --git a/dev-vcs/repo/repo-2.5.ebuild b/dev-vcs/repo/repo-2.5.ebuild
new file mode 100644
index 000000000000..5664a3767c19
--- /dev/null
+++ b/dev-vcs/repo/repo-2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}