summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-10-14 22:15:24 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-10-14 22:15:51 +0100
commit30d60414d4ee457fbb0fdb2edeb016de93faf6b4 (patch)
tree57b63fe1fed6b412d2b2a29862ae7353b514059c /dev-vcs
parentnet-dns/unbound: added version 1.8.1 (diff)
downloadgentoo-30d60414d4ee457fbb0fdb2edeb016de93faf6b4.tar.gz
gentoo-30d60414d4ee457fbb0fdb2edeb016de93faf6b4.tar.bz2
gentoo-30d60414d4ee457fbb0fdb2edeb016de93faf6b4.zip
dev-vcs/cvs-fast-export: bump up to 1.44, bug #668640
Reported-by: jy6x2b32pie9@yahoo.com Closes: https://bugs.gentoo.org/668640 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvs-fast-export/Manifest1
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.44.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index 4e7da6c631fa..7f37f60b1c09 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1,2 +1,3 @@
DIST cvs-fast-export-1.26.tar.gz 668913 BLAKE2B ff2437eb55ae909666f94d79475e3ccf8db0b9491c439094090bc0eda3ef300b99becb7811aa824aced47039686df0d23c9307b3f35ac3d3cad88e78ce93c549 SHA512 81d240ae387b4231415335b4a0d294ae81f6ecbc97077d92a1738aca17642b9a7e7ee3f7806890ceafc5c65c50d4370c39c36ee21c927a4fcd30ebfa3bbe472e
DIST cvs-fast-export-1.38.tar.gz 396524 BLAKE2B 41e7d5210671aae9063d3fa1da8a61ff581cdbe6745573d158576e495aeba0958d1cf20c9d8435e0c12747428b884eeab3b2d926a93d580589f17db8102ad27e SHA512 ed2aabc417b093c1742ea15bd21855c600a46a5ab72758d15bab24672b6e648531416a6b28c17e6faedd67b4c697b004ba3316cd65cb0ec638566c26878e9428
+DIST cvs-fast-export-1.44.tar.gz 512435 BLAKE2B 2dfcd34efbf400c9d9a726933a18504a8d241928646d73f54f1860d1580030fa0328df4aaf5b57f1fbdc4b7b2c0a988ac903c8f9f03384515fdd5241fbf51c06 SHA512 66209589c692d2b0b2e60494386cb4dbae04f5f6676c89733d3ad6e5ce8b76d3cb70d7b03430be643e44eaff5848fdb7413795e10716a9ed8b4f2a4043f822a5
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.44.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.44.ebuild
new file mode 100644
index 000000000000..3ad6a6b004d1
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.44.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship some tests in tarball
+
+src_prepare() {
+ default
+
+ tc-export CC
+ export prefix=/usr
+
+ # respect CC, CFLAGS and LDFLAGS
+ sed \
+ -e 's/cc /$(CC) $(LDFLAGS) /' \
+ -e 's/^CFLAGS += -O/#&/' \
+ -e 's/CFLAGS=/CFLAGS+=/' \
+ -i Makefile || die
+}
+
+src_install() {
+ default
+ dodoc README
+}