summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2016-03-08 20:35:04 -0600
committerDoug Goldstein <cardoe@gentoo.org>2016-03-08 20:35:26 -0600
commit434b56da192bcf02421b95bce40a87c64b262774 (patch)
tree8ab0eab2b8eb23ab2344360a4a753d96ed1c8d39 /dev-vcs
parentnet-analyzer/wireshark: Use upstream .desktop files (bug #576442 by Jan Chren... (diff)
downloadgentoo-434b56da192bcf02421b95bce40a87c64b262774.tar.gz
gentoo-434b56da192bcf02421b95bce40a87c64b262774.tar.bz2
gentoo-434b56da192bcf02421b95bce40a87c64b262774.zip
dev-vcs/git-tools: fix git whatchanged
This fix was submitted upstream as PR21 by dwfreed. robbat2 requested this be committed. Package-Manager: portage-2.2.26 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-tools/files/git-tools-2015_p20160201-pr21.patch27
-rw-r--r--dev-vcs/git-tools/git-tools-2015_p20160201-r1.ebuild51
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-vcs/git-tools/files/git-tools-2015_p20160201-pr21.patch b/dev-vcs/git-tools/files/git-tools-2015_p20160201-pr21.patch
new file mode 100644
index 000000000000..f921efd9be22
--- /dev/null
+++ b/dev-vcs/git-tools/files/git-tools-2015_p20160201-pr21.patch
@@ -0,0 +1,27 @@
+diff --git a/git-restore-mtime b/git-restore-mtime
+index fbc05d9..7bbd375 100755
+--- a/git-restore-mtime
++++ b/git-restore-mtime
+@@ -74,6 +74,14 @@ parser.add_argument('--merge', '-m',
+ 'sometimes substantially. By default merge logs are only '
+ 'used for files missing from regular commit logs.')
+
++parser.add_argument('--first-parent',
++ action="store_true",
++ help='pass --first-parent to git whatchanged to hide the '
++ 'second parent from the merge commit logs. Only has any '
++ 'effect if --merge is also specified or --skip-missing '
++ 'is not specified and there were files not found in regular '
++ 'commit logs.')
++
+ parser.add_argument('--skip-missing', '-s',
+ action="store_false", default=True, dest='missing',
+ help='do not try to find missing files. If some files were '
+@@ -252,6 +260,7 @@ def parselog(merge=False, filterlist=[]):
+
+ gitobj = subprocess.Popen(gitcmd + shlex.split('whatchanged --pretty={}'.format(args.timeformat)) +
+ (['-m'] if merge else []) +
++ (['--first-parent'] if args.first_parent else []) +
+ ['--'] + filterlist,
+ stdout=subprocess.PIPE)
+ for line in gitobj.stdout: \ No newline at end of file
diff --git a/dev-vcs/git-tools/git-tools-2015_p20160201-r1.ebuild b/dev-vcs/git-tools/git-tools-2015_p20160201-r1.ebuild
new file mode 100644
index 000000000000..042b05433c81
--- /dev/null
+++ b/dev-vcs/git-tools/git-tools-2015_p20160201-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{1..5} )
+inherit eutils python-r1
+
+DESCRIPTION="Assorted git-related scripts"
+HOMEPAGE="https://github.com/MestreLion/git-tools/"
+MY_PV="0431b5f4c59101c1b7250d8dd2ce3f6a22318bc6"
+SRC_URI="https://github.com/MestreLion/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ >=dev-vcs/git-2.5
+ >=app-shells/bash-4.0"
+
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "$FILESDIR"/git-tools-2015_p20151225-py3.patch
+ epatch "$FILESDIR"/${P}-pr21.patch
+
+ epatch_user
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ SCRIPTS_BASH="git-branches-rename git-clone-subset git-find-uncommitted-repos git-rebase-theirs git-strip-merge"
+ SCRIPTS_PYTHON="git-restore-mtime"
+ dobin $SCRIPTS_BASH
+ dobin $SCRIPTS_PYTHON
+ for p in $SCRIPTS_PYTHON ; do
+ python_replicate_script "${ED}"/usr/bin/$p
+ done
+ # Make it possible to use the tools as 'git $TOOLNAME'
+ for i in $SCRIPTS_BASH $SCRIPTS_PYTHON ; do
+ dosym /usr/bin/$i /usr/libexec/git-core/$i
+ done
+ dodoc README.md
+}