summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-04 10:01:34 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-04 10:01:34 +0200
commit5c5e30bc28fc993f141cee88a55aa6315be87999 (patch)
tree632d0811658799b11b763a0f94309371e65e711a /dev-vcs
parentnet-ftp/filezilla: Removed old. (diff)
downloadgentoo-5c5e30bc28fc993f141cee88a55aa6315be87999.tar.gz
gentoo-5c5e30bc28fc993f141cee88a55aa6315be87999.tar.bz2
gentoo-5c5e30bc28fc993f141cee88a55aa6315be87999.zip
dev-vcs/tortoisehg: Bump to version 3.9
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-3.9.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 94f7f533552e..6375c6fedcd7 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -1,3 +1,4 @@
DIST tortoisehg-3.7.3.tar.gz 7806350 SHA256 b0055ef6bee59244356179d5af98ffe200388133b17cd4ab5831b979b78a50ed SHA512 5ff57b98b93083cc78e161566f045474e70d474dab98ee99eaa6f453ac2521276a8384563a2e738a786a3c9cbe4c118837a8c534cfd4671c323eab261252e6f9 WHIRLPOOL 9a6e573b22b6dcf328a656dcd9e4f2bd500fc74f03f6d9ee8d350ec35cd7a02f239f6aa290b6ff9414d4b7aedde0b3003296f3520463669ce4f9b75a85a820ba
DIST tortoisehg-3.8.3.tar.gz 7817490 SHA256 63045857067120b3e5d4bb3ff87985b9caeac27ca2e69df5946ab1a0282d08c8 SHA512 1c1d0e7d3eae0a894b09d13223eae3eb43555ea0136372c881f35c4ff1beeb768a059be2484fed72588cadc90a0f83f4dffc6dd7a75a91433751eb4bb37f115f WHIRLPOOL 9049db76419a8cc658180e4d8d4ce7c416850830d8a71add07ac6cf441cb10229572914bddee1643d618f70d54b6d6cbad5f9356a7b580e090f4137f98aef738
DIST tortoisehg-3.8.4.tar.gz 7817508 SHA256 c8608ab7f063d0edd46c1fdae3181ef8216ea029bca34f180f0adeefc50274f7 SHA512 d9d83007588e8e62a03976a229a7c325e6e7f203d4f8fc74cc32b3f2880a1873237b4c333cfdb0ece6acde51019f6f62a75d863f1f99e8a5930ad17c38c6358b WHIRLPOOL 0ae8136f8de546a50998672bfd892774d4e8497268ffaf1198c84ce725c02080e8631c203103f8c646ef3ad7b69c832124042d6d0c207e90d13e08b532d33862
+DIST tortoisehg-3.9.tar.gz 7816824 SHA256 7f0eac2bb1d2540a05993390f1ebdaa62f2a98160eeee6e8129a665c4d88c19e SHA512 5b67a98e9503974d7dfe001178c3343f7426a17b2ddc5f9ad67fd3c7a372a5d153903ec40e2906a3eefa6c8b994a9f08b0f6d8733668b15731e8bd6fc8a5b69a WHIRLPOOL 15dc2361bbae3a1829e0b0e3d96ffeb5d05f3f76a703ab362fc004b471046bf1d7c7310681446a06ab2492d64c92681e493e7fca5eb8241682639318ca060fb4
diff --git a/dev-vcs/tortoisehg/tortoisehg-3.9.ebuild b/dev-vcs/tortoisehg/tortoisehg-3.9.ebuild
new file mode 100644
index 000000000000..d6b86c8f9a81
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-3.9.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-3.8 <dev-vcs/mercurial-3.10"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ EHG_REVISION="stable"
+ KEYWORDS=""
+ SRC_URI=""
+ HG_DEPEND="dev-vcs/mercurial"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt4[svg,${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+# Workaround race condition in build_qt
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ if [[ ${LINGUAS+set} ]]; then
+ cd i18n/tortoisehg || die
+ local x y keep
+ for x in *.po; do
+ keep=false
+ for y in ${LINGUAS}; do
+ if [[ ${y} == ${x%.po}* ]]; then
+ keep=true
+ break
+ fi
+ done
+ ${keep} || rm "${x}" || die
+ done
+ cd "${S}" || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ if use doc ; then
+ dohtml -r doc/build/html/
+ fi
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+}
+
+pkg_postinst() {
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt4 please rebuild"
+ elog "dev-python/qscintilla-python."
+}