summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-17 11:03:12 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-17 11:03:30 +0200
commit5d37f5093faef6659fdb913e13d2c9d016c79cba (patch)
treebd6017fac3e42943e9420e57e768f89ea9121335 /dev-vcs
parentdev-vcs/mercurial: Bump to version 3.8.2 (diff)
downloadgentoo-5d37f5093faef6659fdb913e13d2c9d016c79cba.tar.gz
gentoo-5d37f5093faef6659fdb913e13d2c9d016c79cba.tar.bz2
gentoo-5d37f5093faef6659fdb913e13d2c9d016c79cba.zip
dev-vcs/mercurial: Removed old.
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/mercurial-3.8.1.ebuild140
1 files changed, 0 insertions, 140 deletions
diff --git a/dev-vcs/mercurial/mercurial-3.8.1.ebuild b/dev-vcs/mercurial/mercurial-3.8.1.ebuild
deleted file mode 100644
index 18f93f985ef2..000000000000
--- a/dev-vcs/mercurial/mercurial-3.8.1.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads"
-
-inherit bash-completion-r1 elisp-common eutils distutils-r1 flag-o-matic
-
-DESCRIPTION="Scalable distributed SCM"
-HOMEPAGE="http://mercurial.selenic.com/"
-SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bugzilla emacs gpg test tk"
-
-RDEPEND="bugzilla? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
- gpg? ( app-crypt/gnupg )
- tk? ( dev-lang/tk )
- app-misc/ca-certificates"
-DEPEND="emacs? ( virtual/emacs )
- test? ( app-arch/unzip
- dev-python/pygments[${PYTHON_USEDEP}] )"
-
-SITEFILE="70${PN}-gentoo.el"
-
-PATCHES=( "${FILESDIR}/${PN}-3.0.1-po_fixes.patch" )
-
-python_prepare_all() {
- # fix up logic that won't work in Gentoo Prefix (also won't outside in
- # certain cases), bug #362891
- sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- strip-flags -ftracer -ftree-vectorize
- # Note: make it impl-conditional if py3 is supported
- append-flags -fno-strict-aliasing
-
- "${PYTHON}" setup.py build_mo || die
-}
-
-python_compile_all() {
- rm -r contrib/{win32,macosx} || die
- if use emacs; then
- cd contrib || die
- elisp-compile mercurial.el || die "elisp-compile failed!"
- fi
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- newbashcomp contrib/bash_completion hg
-
- insinto /usr/share/zsh/site-functions
- newins contrib/zsh_completion _hg
-
- rm -f doc/*.?.txt
- dodoc CONTRIBUTORS
- cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
-
- dobin hgeditor
- dobin contrib/hgk
- python_foreach_impl python_doscript contrib/hg-ssh
-
- if use emacs; then
- elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-
- local RM_CONTRIB=(hgk hg-ssh bash_completion zsh_completion wix buildrpm plan9
- *.el mercurial.spec)
- for f in ${RM_CONTRIB[@]}; do
- rm -r contrib/$f || die
- done
-
- dodoc -r contrib
- docompress -x /usr/share/doc/${PF}/contrib
- doman doc/*.?
-
- cat > "${T}/80mercurial" <<-EOF
-HG="${EPREFIX}/usr/bin/hg"
-EOF
- doenvd "${T}/80mercurial"
-
- insinto /etc/mercurial/hgrc.d
- doins "${FILESDIR}/cacerts.rc"
-}
-
-src_test() {
- pushd tests &>/dev/null || die
- rm -rf *svn* # Subversion tests fail with 1.5
- rm -f test-archive* # Fails due to verbose tar output changes
- rm -f test-convert-baz* # GNU Arch baz
- rm -f test-convert-cvs* # CVS
- rm -f test-convert-darcs* # Darcs
- rm -f test-convert-git* # git
- rm -f test-convert-mtn* # monotone
- rm -f test-convert-tla* # GNU Arch tla
- #rm -f test-doctest* # doctest always fails with python 2.5.x
- rm -f test-largefiles* # tends to time out
-
- popd &>/dev/null || die
- distutils-r1_src_test
-}
-
-python_test() {
- local TEST_DIR
-
- rm -rf "${TMPDIR}"/test
- distutils_install_for_testing
- cd tests || die
- "${PYTHON}" run-tests.py --verbose \
- --tmpdir="${TMPDIR}"/test \
- --with-hg="${TEST_DIR}"/scripts/hg \
- || die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-
- elog "If you want to convert repositories from other tools using convert"
- elog "extension please install correct tool:"
- elog " dev-vcs/cvs"
- elog " dev-vcs/darcs"
- elog " dev-vcs/git"
- elog " dev-vcs/monotone"
- elog " dev-vcs/subversion"
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}