summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2020-03-15 11:24:28 +0100
committerCédric Krier <cedk@gentoo.org>2020-03-16 12:03:14 +0100
commit7a0eb5cfdc61e517ac28c13cd3832e92b96fd1a3 (patch)
tree4d7c82dc80606927414bf4c0d3c369a63abaf437 /dev-vcs
parentdev-vcs/mercurial: Version bumps (diff)
downloadgentoo-7a0eb5cfdc61e517ac28c13cd3832e92b96fd1a3.tar.gz
gentoo-7a0eb5cfdc61e517ac28c13cd3832e92b96fd1a3.tar.bz2
gentoo-7a0eb5cfdc61e517ac28c13cd3832e92b96fd1a3.zip
dev-vcs/mercurial: Use filter-flags instead of strip-flags
Closes: https://bugs.gentoo.org/712594 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Cédric Krier <cedk@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/mercurial-4.6.2.ebuild2
-rw-r--r--dev-vcs/mercurial/mercurial-4.9-r2.ebuild2
-rw-r--r--dev-vcs/mercurial/mercurial-4.9.1.ebuild2
-rw-r--r--dev-vcs/mercurial/mercurial-5.0.2.ebuild2
-rw-r--r--dev-vcs/mercurial/mercurial-5.1.2.ebuild2
-rw-r--r--dev-vcs/mercurial/mercurial-5.2.2-r1.ebuild2
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild2
7 files changed, 7 insertions, 7 deletions
diff --git a/dev-vcs/mercurial/mercurial-4.6.2.ebuild b/dev-vcs/mercurial/mercurial-4.6.2.ebuild
index 135710a8f27a..1c5db61c0499 100644
--- a/dev-vcs/mercurial/mercurial-4.6.2.ebuild
+++ b/dev-vcs/mercurial/mercurial-4.6.2.ebuild
@@ -41,7 +41,7 @@ python_prepare_all() {
}
python_configure_all() {
- strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+ filter-flags -ftracer -ftree-vectorize
# Note: make it impl-conditional if py3 is supported
append-flags -fno-strict-aliasing
diff --git a/dev-vcs/mercurial/mercurial-4.9-r2.ebuild b/dev-vcs/mercurial/mercurial-4.9-r2.ebuild
index 25fa556dc7ae..a878d8730ad6 100644
--- a/dev-vcs/mercurial/mercurial-4.9-r2.ebuild
+++ b/dev-vcs/mercurial/mercurial-4.9-r2.ebuild
@@ -49,7 +49,7 @@ python_prepare_all() {
}
python_configure_all() {
- strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+ filter-flags -ftracer -ftree-vectorize
# Note: make it impl-conditional if py3 is supported
append-flags -fno-strict-aliasing
diff --git a/dev-vcs/mercurial/mercurial-4.9.1.ebuild b/dev-vcs/mercurial/mercurial-4.9.1.ebuild
index c50921ab4f38..435caf12f6ea 100644
--- a/dev-vcs/mercurial/mercurial-4.9.1.ebuild
+++ b/dev-vcs/mercurial/mercurial-4.9.1.ebuild
@@ -49,7 +49,7 @@ python_prepare_all() {
}
python_configure_all() {
- strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+ filter-flags -ftracer -ftree-vectorize
# Note: make it impl-conditional if py3 is supported
append-flags -fno-strict-aliasing
diff --git a/dev-vcs/mercurial/mercurial-5.0.2.ebuild b/dev-vcs/mercurial/mercurial-5.0.2.ebuild
index 8e116e668203..117dc6be168c 100644
--- a/dev-vcs/mercurial/mercurial-5.0.2.ebuild
+++ b/dev-vcs/mercurial/mercurial-5.0.2.ebuild
@@ -49,7 +49,7 @@ python_prepare_all() {
}
python_configure_all() {
- strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+ filter-flags -ftracer -ftree-vectorize
# Note: make it impl-conditional if py3 is supported
append-flags -fno-strict-aliasing
diff --git a/dev-vcs/mercurial/mercurial-5.1.2.ebuild b/dev-vcs/mercurial/mercurial-5.1.2.ebuild
index 24db3c875e13..88464e063967 100644
--- a/dev-vcs/mercurial/mercurial-5.1.2.ebuild
+++ b/dev-vcs/mercurial/mercurial-5.1.2.ebuild
@@ -49,7 +49,7 @@ python_prepare_all() {
}
python_configure_all() {
- strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+ filter-flags -ftracer -ftree-vectorize
# Note: make it impl-conditional if py3 is supported
append-flags -fno-strict-aliasing
diff --git a/dev-vcs/mercurial/mercurial-5.2.2-r1.ebuild b/dev-vcs/mercurial/mercurial-5.2.2-r1.ebuild
index 5ee7bb5b45f8..6cf8acb5c9cc 100644
--- a/dev-vcs/mercurial/mercurial-5.2.2-r1.ebuild
+++ b/dev-vcs/mercurial/mercurial-5.2.2-r1.ebuild
@@ -55,7 +55,7 @@ python_prepare_all() {
}
python_compile() {
- strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+ filter-flags -ftracer -ftree-vectorize
python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile build_ext --no-zstd
}
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index 6a75f6d2818d..a62bf9062fdc 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -57,7 +57,7 @@ python_prepare_all() {
}
python_compile() {
- strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
+ filter-flags -ftracer -ftree-vectorize
python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile build_ext --no-zstd
}