summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-05-24 13:57:06 +0200
committerMichał Górny <mgorny@gentoo.org>2016-05-24 14:45:08 +0200
commit7b09ad3631973caeb05876d8e62d2f6af378ab77 (patch)
tree72c0a198270dbce07bcb0e729f422d369024bf2c /dev-vcs
parentdev-vcs/git-bz: Update and clean up the live ebuild (diff)
downloadgentoo-7b09ad3631973caeb05876d8e62d2f6af378ab77.tar.gz
gentoo-7b09ad3631973caeb05876d8e62d2f6af378ab77.tar.bz2
gentoo-7b09ad3631973caeb05876d8e62d2f6af378ab77.zip
dev-vcs/git-bz: Snapshot bump
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-bz/Manifest1
-rw-r--r--dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-vcs/git-bz/Manifest b/dev-vcs/git-bz/Manifest
index 50a890a5361b..dc7f7700dec9 100644
--- a/dev-vcs/git-bz/Manifest
+++ b/dev-vcs/git-bz/Manifest
@@ -1,2 +1,3 @@
DIST git-bz-0.12.04.26.tar.bz2 35224 SHA256 5b78df3972aace9de508329121861641517058a10f58d08f6ae6820cf32d0918 SHA512 1e216e8c583599c8c9633b6a02a205368aeab8746bc8eeb9a0347025cce689fccd8c157e66e0fafb33536fa52b1a97ed82467ce6ec9cb494bca2ad9ad18a7ed8 WHIRLPOOL df50ea90781b2a39618f40323efda44d259305cfc951bd1c8a133dd19584d869df8ad8e07eae3d97c5b16c36c4ec22041ea0ebba48b3ba6de8d6febdada0ca36
DIST git-bz-0.12.12.15.tar.bz2 42590 SHA256 cb56dd495528c355f85a889506e98508ede4f41f20c431e4af36746b0b2a6b4f SHA512 b008a35a7d8e3902ade12aed3c8474fdde790cc1881c5e8133142cc438a4335c08a14b082e41d6dd2ac179425a576144d88212ff1ebe3322c27f98ebbac506d1 WHIRLPOOL 32f221dc33d39b054e885c30e721a110a4dfe1995df61982f2204a88cac003a44c8691a3c20d51953267f2f1896051777958607e05128372f7c0da4011738429
+DIST git-bz-0.2015.09.08.tar.bz2 46980 SHA256 657e2020021f7e7cc1529475a8ab47ac59366078a30a83334dbf77e81360955e SHA512 8a468183f23d182ea566ceb524b05028c483e5eecc0c8babec42d67e99b8779af430d18373e130dcc13c8c58135ac62faf0a700c2731320617b47b00f5678133 WHIRLPOOL 9e00226f514d69c51dc43df8c2be3f9d95f3f11bbe38ef4df628ba359cdd3dea34847a570205a25dd4f14c53b23132db42d46a09c44e58f3ec37e1fa63a09e7a
diff --git a/dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild b/dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild
new file mode 100644
index 000000000000..fb96afcb463f
--- /dev/null
+++ b/dev-vcs/git-bz/git-bz-0.2015.09.08.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE='sqlite'
+
+inherit python-single-r1
+
+DESCRIPTION="Bugzilla subcommand for git"
+HOMEPAGE="http://www.fishsoup.net/software/git-bz/"
+SRC_URI="http://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+
+src_configure() {
+ # custom script
+ ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_install() {
+ default
+ python_fix_shebang "${ED%/}"/usr/bin/${PN}
+}
+
+pkg_postinst() {
+ if ! has_version dev-python/pycrypto; then
+ elog "For Chrome/-ium cookie decryption support, please install:"
+ elog " dev-python/pycrypto"
+ fi
+}