summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-01 00:19:17 +0000
committerMarek Szuba <marecki@gentoo.org>2022-01-01 00:23:24 +0000
commit86b5f7e50ff37dd6d437aae4c9cf58e938974c51 (patch)
tree8757ac9bc419248cd746e392b8dfaa8613848701 /dev-vcs
parentdev-python/pyopencl: add 2021.2.11 (diff)
downloadgentoo-86b5f7e50ff37dd6d437aae4c9cf58e938974c51.tar.gz
gentoo-86b5f7e50ff37dd6d437aae4c9cf58e938974c51.tar.bz2
gentoo-86b5f7e50ff37dd6d437aae4c9cf58e938974c51.zip
dev-vcs/pre-commit: add 2.16.0, drop 2.13.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/Manifest2
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.16.0.ebuild (renamed from dev-vcs/pre-commit/pre-commit-2.13.0.ebuild)15
2 files changed, 8 insertions, 9 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index c714de0e5c04..53c31ee53a78 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,2 +1,2 @@
-DIST pre-commit-2.13.0.tar.gz 252631 BLAKE2B 7e6b3af46dfaf9928d2cb2aa6cad05423bf6e417e2324af71b241e1aaa2eec6fcb271869f98c040cd4fb8c608a1fabd244c8286864f469a06c44684cd2bf33eb SHA512 5dfc297b3f900afef8f1c355b38ce086af7c836d1e577af8ec95ffb30e82df8b866131da4ff12933339bda63e4a90833c3852265d4f2d4a59bf92bce2b972a5e
DIST pre-commit-2.15.0.tar.gz 255545 BLAKE2B 8fbb1fd6b1298ff1c5a6884dae53c79d108e8c4b74d05d6be36d562327fd024432d60e6df4570217e1b3f4ad8e33ee4d0d54a5d940f4833a46d4e9cb59698b3c SHA512 b87985aa625509d7a21e31e5774f259c264ec74fef88fc5e290cbac0326cdbadc37ab54b5bf3048d815cf9bc6d4adb71619fcb84c955c1bc9741da8dfd34251c
+DIST pre-commit-2.16.0.tar.gz 256930 BLAKE2B e515dcc9109c91cc7ab5ce60f662ebd62cce4f23e32676b7c295332c959fa10a34c320a197d15d7307b94aee53e7ade5da62aed8bbe122262db15d88d82e9757 SHA512 c9eb14a40e25e8408c2b2b5687eba4908d609bbb7bcf58a0153326696d272bca555156fd75f3ec5f0dec219aeeb4084df77f329f47cf190e40052c11e92fe185
diff --git a/dev-vcs/pre-commit/pre-commit-2.13.0.ebuild b/dev-vcs/pre-commit/pre-commit-2.16.0.ebuild
index b950b9251989..a75c6d3fd4cb 100644
--- a/dev-vcs/pre-commit/pre-commit-2.13.0.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-2.16.0.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_REQ_USE="sqlite"
inherit distutils-r1
@@ -16,7 +15,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
# TODO: figure out why these tests - all of which invoke git - fail:
# - tests/main_test.py::test_all_cmds[autoupdate,hook-impl,install,install-hooks,migrate-config,run,uninstall],
@@ -32,10 +31,10 @@ RESTRICT="test"
RDEPEND="dev-vcs/git
$(python_gen_cond_dep '
- dev-python/cfgv[${PYTHON_USEDEP}]
- dev-python/identify[${PYTHON_USEDEP}]
- dev-python/nodeenv[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
')"