summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2020-02-19 18:42:46 -0500
committerMike Frysinger <vapier@gentoo.org>2020-02-19 18:42:52 -0500
commit8f9b20902029858d5f2b55dfd5ab4a6ed3768c78 (patch)
treecb4bc6c1a44992031a05324556147891b8339390 /dev-vcs
parentdev-libs/libgusb: default enable USE=vala (diff)
downloadgentoo-8f9b20902029858d5f2b55dfd5ab4a6ed3768c78.tar.gz
gentoo-8f9b20902029858d5f2b55dfd5ab4a6ed3768c78.tar.bz2
gentoo-8f9b20902029858d5f2b55dfd5ab4a6ed3768c78.zip
dev-vcs/repo: add 1.27 for frozen python2 branch
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/repo/Manifest1
-rw-r--r--dev-vcs/repo/repo-1.27.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index 7099d301c88f..917cc976b137 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1,2 +1,3 @@
DIST repo-1.26 29829 BLAKE2B c5dc74214d404e6c11189a3d34c9a771ed5689da14e64588b5db144b6ea3ec38a727238d7dc6e609a22edb5b84d350210564615016f6b36599cf9e3fc3b34ef9 SHA512 1398fab95b4fb4a24fda93d4054384a801b5b70e3dca3a794f458d8e19582ef833ef5a3a0f3a571121d2d9172ce0e70f8b3c6719f6c2f47643ffe6de181e34b4
+DIST repo-1.27 29945 BLAKE2B 930fa876b8889d64c8d12444f4cd59bebbdf9848d455e114fc9306922d931aa721320db65a07c38f705c39950538a1d5ae5ca66e359d2f2e38061d144ac11cb2 SHA512 a9f651e5fd1da1c74b31aebf32d03cf868183fa529eaf2b079015f9e778a2bb7c1ef49e06564703534c45fa1bd7bc5bd3d91a91477c336e549c1208afa74ace6
DIST repo-2.3 31280 BLAKE2B b637a226c19bd04350f25c27924b8c4951be1ae09c3ee3f12643d5e2d983e51ee181b22c553ad7fbf6cc0457e0621fe083e21d8e577cd2b87c74d3cfd107ee69 SHA512 3c83799fbc1846730c085a43c603938b8daa8bb7792e130a55cd508cf416b67fa025e77f20770c6b65f9ee3fa1aa7240d47bfb8e9a3835ac5ea11e1fce9112e2
diff --git a/dev-vcs/repo/repo-1.27.ebuild b/dev-vcs/repo/repo-1.27.ebuild
new file mode 100644
index 000000000000..280f73384ee7
--- /dev/null
+++ b/dev-vcs/repo/repo-1.27.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. They are confusingly different currently.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}