summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-04-09 21:30:02 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-04-09 21:30:15 +0200
commit94454a54314e0b471877ee2d1b44d8a6b9128cea (patch)
tree5b1d776c4e4713e749454c48af01a3beef7f6b6e /dev-vcs
parentsys-apps/ethtool: arm64 stable (bug #680302) (diff)
downloadgentoo-94454a54314e0b471877ee2d1b44d8a6b9128cea.tar.gz
gentoo-94454a54314e0b471877ee2d1b44d8a6b9128cea.tar.bz2
gentoo-94454a54314e0b471877ee2d1b44d8a6b9128cea.zip
dev-vcs/subversion: fix building against >=dev-libs/apr-1.7.0
Closes: https://bugs.gentoo.org/682786 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/subversion/files/subversion-1.11.1-allow-apr-1.7.0+.patch18
-rw-r--r--dev-vcs/subversion/subversion-1.10.4.ebuild4
-rw-r--r--dev-vcs/subversion/subversion-1.11.1.ebuild4
-rw-r--r--dev-vcs/subversion/subversion-1.12.0_rc1.ebuild4
-rw-r--r--dev-vcs/subversion/subversion-1.9.7-r1.ebuild4
5 files changed, 34 insertions, 0 deletions
diff --git a/dev-vcs/subversion/files/subversion-1.11.1-allow-apr-1.7.0+.patch b/dev-vcs/subversion/files/subversion-1.11.1-allow-apr-1.7.0+.patch
new file mode 100644
index 000000000000..a0da4a5931df
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.11.1-allow-apr-1.7.0+.patch
@@ -0,0 +1,18 @@
+--- a/build/ac-macros/swig.m4
++++ b/build/ac-macros/swig.m4
+@@ -137,13 +137,13 @@
+ AC_CACHE_CHECK([for apr_int64_t Python/C API format string],
+ [svn_cv_pycfmt_apr_int64_t], [
+ if test "x$svn_cv_pycfmt_apr_int64_t" = "x"; then
+- AC_EGREP_CPP([MaTcHtHiS +\"lld\" +EnDeNd],
++ AC_EGREP_CPP([MaTcHtHiS +\"ll(\" *\")?d\" +EnDeNd],
+ [#include <apr.h>
+ MaTcHtHiS APR_INT64_T_FMT EnDeNd],
+ [svn_cv_pycfmt_apr_int64_t="L"])
+ fi
+ if test "x$svn_cv_pycfmt_apr_int64_t" = "x"; then
+- AC_EGREP_CPP([MaTcHtHiS +\"ld\" +EnDeNd],r
++ AC_EGREP_CPP([MaTcHtHiS +\"l(\" *\")?d\" +EnDeNd],r
+ [#include <apr.h>
+ MaTcHtHiS APR_INT64_T_FMT EnDeNd],
+ [svn_cv_pycfmt_apr_int64_t="l"])
diff --git a/dev-vcs/subversion/subversion-1.10.4.ebuild b/dev-vcs/subversion/subversion-1.10.4.ebuild
index 27db0ff68b2e..ae74dc6cd387 100644
--- a/dev-vcs/subversion/subversion-1.10.4.ebuild
+++ b/dev-vcs/subversion/subversion-1.10.4.ebuild
@@ -130,6 +130,9 @@ pkg_setup() {
append-cppflags -DSVN_DEBUG -DAP_DEBUG
fi
+ # https://issues.apache.org/jira/browse/SVN-4813#comment-16813739
+ append-cppflags -P
+
# http://mail-archives.apache.org/mod_mbox/subversion-dev/201306.mbox/%3C51C42014.3060700@wandisco.com%3E
[[ ${CHOST} == *-solaris2* ]] && append-cppflags -D__EXTENSIONS__
@@ -152,6 +155,7 @@ pkg_setup() {
src_prepare() {
eapply "${WORKDIR}/patches"
eapply "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
+ eapply "${FILESDIR}"/${PN}-1.11.1-allow-apr-1.7.0+.patch
eapply_user
fperms +x build/transform_libtool_scripts.sh
diff --git a/dev-vcs/subversion/subversion-1.11.1.ebuild b/dev-vcs/subversion/subversion-1.11.1.ebuild
index a4a22eed9157..7510d3694e68 100644
--- a/dev-vcs/subversion/subversion-1.11.1.ebuild
+++ b/dev-vcs/subversion/subversion-1.11.1.ebuild
@@ -126,6 +126,9 @@ pkg_setup() {
echo -ne "\a"
fi
+ # https://issues.apache.org/jira/browse/SVN-4813#comment-16813739
+ append-cppflags -P
+
if use debug ; then
append-cppflags -DSVN_DEBUG -DAP_DEBUG
fi
@@ -152,6 +155,7 @@ pkg_setup() {
src_prepare() {
eapply "${WORKDIR}/patches"
eapply "${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
+ eapply "${FILESDIR}"/${PN}-1.11.1-allow-apr-1.7.0+.patch
eapply_user
fperms +x build/transform_libtool_scripts.sh
diff --git a/dev-vcs/subversion/subversion-1.12.0_rc1.ebuild b/dev-vcs/subversion/subversion-1.12.0_rc1.ebuild
index 088d6446ba45..2f0f32c6f26e 100644
--- a/dev-vcs/subversion/subversion-1.12.0_rc1.ebuild
+++ b/dev-vcs/subversion/subversion-1.12.0_rc1.ebuild
@@ -126,6 +126,9 @@ pkg_setup() {
echo -ne "\a"
fi
+ # https://issues.apache.org/jira/browse/SVN-4813#comment-16813739
+ append-cppflags -P
+
if use debug ; then
append-cppflags -DSVN_DEBUG -DAP_DEBUG
fi
@@ -151,6 +154,7 @@ pkg_setup() {
src_prepare() {
eapply "${WORKDIR}/patches"
+ eapply "${FILESDIR}"/${PN}-1.11.1-allow-apr-1.7.0+.patch
eapply_user
fperms +x build/transform_libtool_scripts.sh
diff --git a/dev-vcs/subversion/subversion-1.9.7-r1.ebuild b/dev-vcs/subversion/subversion-1.9.7-r1.ebuild
index ebe11966889b..6be305333dd6 100644
--- a/dev-vcs/subversion/subversion-1.9.7-r1.ebuild
+++ b/dev-vcs/subversion/subversion-1.9.7-r1.ebuild
@@ -89,6 +89,7 @@ PATCHES=(
"${WORKDIR}"/${PN}-1.8.18-patchset/${PN}-1.8.16-javadoc-nolint.patch
"${FILESDIR}"/${P}-kf5.patch
"${FILESDIR}"/${PN}-1.9.7-fix-wc-queries-test-test.patch
+ "${FILESDIR}"/${PN}-1.11.1-allow-apr-1.7.0+.patch
)
want_apache
@@ -131,6 +132,9 @@ pkg_setup() {
echo -ne "\a"
fi
+ # https://issues.apache.org/jira/browse/SVN-4813#comment-16813739
+ append-cppflags -P
+
if use debug ; then
append-cppflags -DSVN_DEBUG -DAP_DEBUG
fi