summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-08-19 08:17:09 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-08-19 08:17:09 -0400
commit98c51370e5a41918e6cd70364e8270c50acfb04c (patch)
tree97777096f7bf4883a0d1cd3137812c761bf6b3aa /dev-vcs
parentdev-util/kdevplatform: Fix build, switch to KDE_TEST=true (diff)
downloadgentoo-98c51370e5a41918e6cd70364e8270c50acfb04c.tar.gz
gentoo-98c51370e5a41918e6cd70364e8270c50acfb04c.tar.bz2
gentoo-98c51370e5a41918e6cd70364e8270c50acfb04c.zip
dev-vcs/fossil: Bump SQLite version requirement
Fossil 2.3 needs SQLite 3.20.0 or greater. Rename sqlite USE flag to the more descriptive system-sqlite. Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/fossil/fossil-2.3.ebuild6
-rw-r--r--dev-vcs/fossil/metadata.xml3
2 files changed, 6 insertions, 3 deletions
diff --git a/dev-vcs/fossil/fossil-2.3.ebuild b/dev-vcs/fossil/fossil-2.3.ebuild
index f77c89e71296..62e86b97c5f5 100644
--- a/dev-vcs/fossil/fossil-2.3.ebuild
+++ b/dev-vcs/fossil/fossil-2.3.ebuild
@@ -12,14 +12,14 @@ SRC_URI="http://www.fossil-scm.org/index.html/uv/fossil-src-${PV}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="debug fusefs json legacy-mv-rm -miniz sqlite +ssl static tcl th1-docs th1-hooks"
+IUSE="debug fusefs json legacy-mv-rm -miniz system-sqlite +ssl static tcl th1-docs th1-hooks"
REQUIRED_USE="ssl? ( !miniz )"
DEPEND="
sys-libs/zlib
|| ( sys-libs/readline:0 dev-libs/libedit )
- sqlite? ( >=dev-db/sqlite-3.14.0:3 )
+ system-sqlite? ( >=dev-db/sqlite-3.20.0:3 )
ssl? ( dev-libs/openssl:0 )
tcl? ( dev-lang/tcl:0= )
"
@@ -35,7 +35,7 @@ src_configure() {
local myconf="--with-openssl=$(usex ssl auto none)"
use debug && myconf+=' --fossil-debug'
use json && myconf+=' --json'
- use sqlite && myconf+=' --disable-internal-sqlite'
+ use system-sqlite && myconf+=' --disable-internal-sqlite'
use static && myconf+=' --static'
use tcl && myconf+=' --with-tcl --with-tcl-stubs'
diff --git a/dev-vcs/fossil/metadata.xml b/dev-vcs/fossil/metadata.xml
index d956edfbcdca..2017eefa2923 100644
--- a/dev-vcs/fossil/metadata.xml
+++ b/dev-vcs/fossil/metadata.xml
@@ -22,6 +22,9 @@
<flag name="sqlite">
Use the system SQLite instead of the bundled one
</flag>
+ <flag name="system-sqlite">
+ Use the system SQLite instead of the bundled one
+ </flag>
<flag name="th1-docs">
Enable TH1 for embedded documentation pages
</flag>