summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-04-10 21:42:38 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-04-10 21:43:10 +0100
commitaeabf3bd8204271ebeaf1db523de0fa6f65e34f4 (patch)
tree504b46fa211bc5837efb0b426a23da7d58667029 /dev-vcs
parentapp-admin/needrestart: Cleanup old version (diff)
downloadgentoo-aeabf3bd8204271ebeaf1db523de0fa6f65e34f4.tar.gz
gentoo-aeabf3bd8204271ebeaf1db523de0fa6f65e34f4.tar.bz2
gentoo-aeabf3bd8204271ebeaf1db523de0fa6f65e34f4.zip
dev-vcs/cvs-fast-export: bump up to 1.53
Package-Manager: Portage-2.3.98, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvs-fast-export/Manifest1
-rw-r--r--dev-vcs/cvs-fast-export/cvs-fast-export-1.53.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-vcs/cvs-fast-export/Manifest b/dev-vcs/cvs-fast-export/Manifest
index 122e99c4ec03..9764e0aa4f35 100644
--- a/dev-vcs/cvs-fast-export/Manifest
+++ b/dev-vcs/cvs-fast-export/Manifest
@@ -1,2 +1,3 @@
DIST cvs-fast-export-1.51.tar.gz 459647 BLAKE2B ebaa1aeedee5de2b7d76cdb0d91897bc779b2cff9b6ae9ddc5b3872f36792e0e1c3f152e340d50c25c5bbef3c7be4af5a0cc4d7f2fd5f12c722c45c43510afcc SHA512 3b004ad1a295722b7610444be2ff67097e7099fb17fdd1ebd2d237a30ffc2a31e8a90b5344a9488f3ea3abd4e104bdc0cff2d28dd56321df76ae9bf6f25e90f4
DIST cvs-fast-export-1.52.tar.gz 468734 BLAKE2B 2f1783df682b4c42aa8f3ecc6b0bdfbc641a08e92e649bb0de25b1b6d99c87aebe34488ba928570cce7dd6427c3f5cdc4cb7bc2abb3b5da7f43b53b958770b72 SHA512 eac6843c392a6e6820da2291dec3309c6ed309b89ee5c0784160292e8f8157b6d6e127508c37c29dffe32477fafe38b94a45e1036927b5deb040589132863def
+DIST cvs-fast-export-1.53.tar.gz 472991 BLAKE2B 4fb69bbe75cb4a2d54bf876ebefc4e2fbb12e3a22f9cfcd45f31adec6c65406b3b3647513b884f0d3356bf78f0c8b5684024d6bdea41776a68d48f08879e773b SHA512 cd40543d73c2367b76c181d262b12b13223fc66984ce616d2b0df22f9562a99940dcd6e1e4996a237f2f37c5a8ed48992c2cda521b92238b6bb78b4144d0d503
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.53.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.53.ebuild
new file mode 100644
index 000000000000..976b11d8e920
--- /dev/null
+++ b/dev-vcs/cvs-fast-export/cvs-fast-export-1.53.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship some tests in tarball
+
+src_prepare() {
+ default
+
+ tc-export CC
+ export prefix="${EPREFIX}"/usr
+
+ # respect CC, CFLAGS and LDFLAGS
+ sed \
+ -e 's/cc /$(CC) $(LDFLAGS) /' \
+ -e 's/^CFLAGS += -O/#&/' \
+ -e 's/CFLAGS=/CFLAGS+=/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ # '.adoc.html' rules can't be executed in parallel
+ # as they reuse the same 'docbook-xsl.css' file name.
+ emake -j1 html
+ # Allow full parallelism for the rest
+ emake
+}
+
+src_install() {
+ default
+ dodoc README.adoc
+}