summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-13 18:20:31 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-13 18:21:44 +0200
commitb98c9fdb678db172cb941bc12ce2554df31c73b9 (patch)
tree12b6476a6fb2c4bf0b02d2e598b243ab91638c30 /dev-vcs
parentnet-misc/ipv6calc: stable 1.0.0 for hppa, bug #668194 (diff)
downloadgentoo-b98c9fdb678db172cb941bc12ce2554df31c73b9.tar.gz
gentoo-b98c9fdb678db172cb941bc12ce2554df31c73b9.tar.bz2
gentoo-b98c9fdb678db172cb941bc12ce2554df31c73b9.zip
dev-vcs/hgsubversion: Bump to 1.9.2
Closes: https://bugs.gentoo.org/543472 Closes: https://bugs.gentoo.org/631216 Closes: https://bugs.gentoo.org/662766 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hgsubversion/Manifest1
-rw-r--r--dev-vcs/hgsubversion/hgsubversion-1.9.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-vcs/hgsubversion/Manifest b/dev-vcs/hgsubversion/Manifest
index cd70f68b48a6..e0ab7a691487 100644
--- a/dev-vcs/hgsubversion/Manifest
+++ b/dev-vcs/hgsubversion/Manifest
@@ -1,2 +1,3 @@
DIST hgsubversion-1.8.5.tar.gz 179639 BLAKE2B 3fa5dd690e404837ccca7efeef7d873c579f717aaad274bed594aef751338450b347d8e82d3a139d00206e12a6c3979d18355be6c2c3a7ae23d01f51c3be09e8 SHA512 1d3f0824c3b83a2e00485ef3f412767bdb378a5a545f2fcf533eafebb20cbd40becf54cf9a29705200d221d6d6c0eb284fae0692354b1795feb391de2a02ca0c
DIST hgsubversion-1.8.6.tar.gz 180720 BLAKE2B fc3cb8b3b4298a11eab4e7374615b80c7653449efd39f7ac48663a211988654bf173dce7016d8c40efbb60d55ed8884680a2139461fea1537c459cdcd807c176 SHA512 8431e995a9f2c150936af004527fea6d562a34c653af6d51e69afdb10397528bbe7f230d92b18c3d04e2315c7b0078ecfc1bd619be4c2540bb564d50092566c4
+DIST hgsubversion-1.9.2.tar.gz 203801 BLAKE2B dd8f53baf1d12263be1dde75b2a0a9367ea038bc4655322ac8e89c5fafe67cd42ab94f83b2eda2ff28f521b8ef7ecb5034dad0916bb2fdfadeee68e52f75e348 SHA512 e11e0db50702d0fa0c29ac75bde8f943551ff392218656f82672c25635b43ed17d26026af106723875165806577881c268ebb5fb82954add599dcb14b13e4744
diff --git a/dev-vcs/hgsubversion/hgsubversion-1.9.2.ebuild b/dev-vcs/hgsubversion/hgsubversion-1.9.2.ebuild
new file mode 100644
index 000000000000..fdad0a29f398
--- /dev/null
+++ b/dev-vcs/hgsubversion/hgsubversion-1.9.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="hgsubversion is a Mercurial extension for working with Subversion repositories"
+HOMEPAGE="https://bitbucket.org/durin42/hgsubversion/wiki/Home https://pypi.org/project/hgsubversion/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-vcs/mercurial-1.4[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/subvertpy-0.7.4[${PYTHON_USEDEP}]
+ >=dev-vcs/subversion-1.5[python] )
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+# "${PYTHON}" tests/run.py || die "Tests failed under ${EPYTHON}"
+ # Upstream is using nose and the other way simply runs no tests
+ LC_ALL=C nosetests --verbose || die
+}