summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-07-14 18:12:22 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-07-14 18:18:06 -0500
commite2ab799c35e52cbc71e32b3bb63f46aed1526052 (patch)
treea16e65f15d32810a5da8307ebd6fb4c51c556e20 /dev-vcs
parentx11-misc/fireflies: depend on sys-libs/argp-standalone for musl (diff)
downloadgentoo-e2ab799c35e52cbc71e32b3bb63f46aed1526052.tar.gz
gentoo-e2ab799c35e52cbc71e32b3bb63f46aed1526052.tar.bz2
gentoo-e2ab799c35e52cbc71e32b3bb63f46aed1526052.zip
dev-vcs/python-gitlab: add 3.6.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index be0589a0a520..91ed246e2dfe 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -2,3 +2,4 @@ DIST python-gitlab-2.10.1.tar.gz 178899 BLAKE2B 5b0fd1552fca15827d9fa12745d03528
DIST python-gitlab-2.5.0.tar.gz 148916 BLAKE2B f870833a01adac08b71dc402bc11ba9c1be19c920735faf04de9bfca3b1a154706da4bc0475437997e3b03d8c9a56977a6691df05b750d64a1f8b964ecd05612 SHA512 7382f9ea2388c6916f3c7e63df137d73f0fdfb3890a8bbb47e766f3476b6febecd1dcbc588445ae1af1b5f17c9a3e6ed9a931fd9fff010c2c37967eab5440824
DIST python-gitlab-2.6.0.tar.gz 153577 BLAKE2B 4fa0206faa601061fde257988362eca962c9e20f50e5ad57d602a76618581db646f26b035d4d86b9c460ef75f241fcbcdf360419b2e62ec6f95a664ab237d7d2 SHA512 b63dd4657b44fb484d114ceddc1d67465c17560978a8e6b09a9b14634ae6d80bf864b9b4583ddfc102c27c1082f4a015958c30944a734ec635761af524956fbe
DIST python-gitlab-3.5.0.tar.gz 225751 BLAKE2B 25efd5de5addde6cdb19307217080213e8f0aa9b189307fe10fb9af55d8db92752794cf71c3e826629f043dd85d6078dbf9e96418d3e96d38209a5a81629d589 SHA512 fdc719f0cb0bf588390f0f6f0ffc4814bb5135156ecbe96cb4b381a7f93606a49773d1e8a34397a0f3b4522c8867704429070bae7bec6cf34b9e713f0a9c9189
+DIST python-gitlab-3.6.0.tar.gz 235738 BLAKE2B 4ed26f2d8add0fbfdc52bd8d7f61e06b717a2f8b7995b8c75eaf67a20362c259d0c487177ba695310cff11bb0129e49cb3c0058682488da9b8f61b477c4a07f1 SHA512 b2fe2dd62b76929d3acef0c8fc815b91ac5949af47fa43110d461d541ecd943af2e3c7afc94ad4b396b8d8815b4201a65ef7199bf886f5e5b0419b3d9bff2575
diff --git a/dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild
new file mode 100644
index 000000000000..85ac20d563aa
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-3.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+BDEPEND="test? (
+dev-python/coverage[${PYTHON_USEDEP}]
+>=dev-python/pytest-console-scripts-1.3.1[${PYTHON_USEDEP}]
+dev-python/pytest-cov[${PYTHON_USEDEP}]
+>=dev-python/pyyaml-5.2[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=">=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}