summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2017-10-16 14:59:01 +0800
committerYixun Lan <dlan@gentoo.org>2017-10-16 15:02:04 +0800
commitf2751e7270736adf5701baedb178f51477937d9b (patch)
treeac3c1af0d36f14f533ca225f8fadce9227510493 /dev-vcs
parentsys-apps/toybox: Bump (diff)
downloadgentoo-f2751e7270736adf5701baedb178f51477937d9b.tar.gz
gentoo-f2751e7270736adf5701baedb178f51477937d9b.tar.bz2
gentoo-f2751e7270736adf5701baedb178f51477937d9b.zip
dev-vcs/stgit: version bump 0.18
also fix broken HOMEPAGE Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/stgit/Manifest1
-rw-r--r--dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch4
-rw-r--r--dev-vcs/stgit/stgit-0.18.ebuild86
3 files changed, 89 insertions, 2 deletions
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
index 6e87fcab6e55..c1234aaaea76 100644
--- a/dev-vcs/stgit/Manifest
+++ b/dev-vcs/stgit/Manifest
@@ -2,3 +2,4 @@ DIST stgit-0.16-missing-patches.tar.gz 1667 SHA256 f105bb417592be3c68d830ad1cf2e
DIST stgit-0.16.tar.gz 362687 SHA256 02f1a19350ccf4a26abac1421df8c2d021e78f995c913f9562718a1700318a42 SHA512 782de3d5855aad4f5d040478745990517ebe2b26dc315a3ed41db95399bb46e075d63a70baa0e3aa2ab1012b59e6ad1f5940a904f296ef09d6bca60f66e417dd WHIRLPOOL e2334c041cb260455d549d33b6628fd4f6e1e7da850f2987ba86922504e07aed8177d092550348b52cad8894b0335d20ee1608b855fa1cb6545bdd301a9d38f1
DIST stgit-0.17.1-upstream-patches-1.tar.xz 15324 SHA256 4ec973ee6a16daee616c5f675294e9351e4953b4d171059cddb504d286939cd3 SHA512 2d756d960b5bd803258afe0bb89cb29a960bc2745adf37f2b574fd114579a867ec51628f2267744ec2eec70090376274bfd720a612093a36f4bb8e4ecb8f6d30 WHIRLPOOL 538a060e8628b9d43af56568a267c2026a9088156af188d5a745adfbb11807dcf948f216e6492d51069c85e80985f156196df6b28eb2664b3e5e27a09b169c57
DIST stgit-0.17.1.tar.gz 398466 SHA256 d43365a0c22e41a6fb9ba1a86de164d6475e79054e7f33805d6a829eb4056ade SHA512 3efdfb9bc024c3a7c0d74d49e85f157d5d5209c9a2ad0ce63a07138c02fb1580e92ac4a91796e79bbd221e6884317e975f9f44e35db0b484fd916bc67cd61abe WHIRLPOOL a7c4c83cfeace12ced60e846ed9daaffadea3ed201a90e72239e3f8df310164e00ce5a89174df177f89df4a609a66ac35e905f31419ed654081c3ab0c2cba859
+DIST stgit-0.18.tar.gz 235852 SHA256 00c83a0a057ee61a300f2291b8926f85521ffd1c92b4cb5152e2be3bf836d3a5 SHA512 5820cc1a8cdd5183fbe309b4b80568098844ff57934c75a43263b5cfcdac4b64e015abc9ed6a53dd856236d76bd0ebeec31e87561bca0d0d82a6e5ec7a10745f WHIRLPOOL 330f97dd43cc0c617d2cdd5eafccf332e1e1debf916d596370f75b02b6a77abc22f0543f397d72f1db3c4a0a539221d2eee4ab82db9c983607108ae15bb2f18d
diff --git a/dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch b/dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch
index 83fdb5457879..559cf8fa789a 100644
--- a/dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch
+++ b/dev-vcs/stgit/files/stgit-0.16-man-linkfix.patch
@@ -1,5 +1,5 @@
---- Documentation/Makefile.old 2012-07-08 23:55:38.958779174 +0200
-+++ Documentation/Makefile 2012-07-08 23:56:42.638010483 +0200
+--- a/Documentation/Makefile 2012-07-08 23:55:38.958779174 +0200
++++ b/Documentation/Makefile 2012-07-08 23:56:42.638010483 +0200
@@ -72,7 +72,7 @@
$(ASCIIDOC) -b xhtml11 -d manpage -f asciidoc.conf $(ASCIIDOC_EXTRA) $<
diff --git a/dev-vcs/stgit/stgit-0.18.ebuild b/dev-vcs/stgit/stgit-0.18.ebuild
new file mode 100644
index 000000000000..9ecaaef68946
--- /dev/null
+++ b/dev-vcs/stgit/stgit-0.18.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+UPSTREAM_VER=
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.16-man-linkfix.patch"
+)
+
+pkg_setup() {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+python_prepare_all() {
+ # Upstream's patchset
+ if [[ -n ${UPSTREAM_VER} ]]; then
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"/patches-upstream
+ fi
+
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ sed -i -e 's/version\.write_builtin_version()//' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ # bug 526468
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ doc
+ fi
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ install-doc install-html
+ fi
+
+ distutils-r1_src_install
+
+ newbashcomp stgit-completion.bash 'stg'
+}