summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Schneider <qsx@qsx.re>2019-03-28 18:23:13 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-28 18:27:25 +0100
commitfa555fd699a20d1c3cf379baa3f2666196fb9b29 (patch)
tree5406332eec3b52297bf4f62e47f1c59508691cf2 /dev-vcs
parentnet-dns/unbound: drop vulnerable wrt bug #677054 (diff)
downloadgentoo-fa555fd699a20d1c3cf379baa3f2666196fb9b29.tar.gz
gentoo-fa555fd699a20d1c3cf379baa3f2666196fb9b29.tar.bz2
gentoo-fa555fd699a20d1c3cf379baa3f2666196fb9b29.zip
dev-vcs/mercurial: Install contrib/chg
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Thomas Schneider <qsx@qsx.re> Closes: https://github.com/gentoo/gentoo/pull/11525 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial/mercurial-4.9-r1.ebuild (renamed from dev-vcs/mercurial/mercurial-4.9.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-vcs/mercurial/mercurial-4.9.ebuild b/dev-vcs/mercurial/mercurial-4.9-r1.ebuild
index e0bacc4958f8..2c1934673ed4 100644
--- a/dev-vcs/mercurial/mercurial-4.9.ebuild
+++ b/dev-vcs/mercurial/mercurial-4.9-r1.ebuild
@@ -58,6 +58,7 @@ python_configure_all() {
python_compile_all() {
rm -r contrib/win32 || die
+ emake -C contrib/chg
if use emacs; then
cd contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
@@ -85,7 +86,10 @@ python_install_all() {
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
- local RM_CONTRIB=( hgk hg-ssh bash_completion zsh_completion wix plan9 *.el )
+ dobin contrib/chg/chg
+ doman contrib/chg/chg.1
+
+ local RM_CONTRIB=( chg hgk hg-ssh bash_completion zsh_completion wix plan9 *.el )
for f in ${RM_CONTRIB[@]}; do
rm -r contrib/${f} || die
done