summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2019-06-30 10:35:22 +0200
committerJohannes Huber <johu@gentoo.org>2019-06-30 10:36:05 +0200
commitfa8312f5798174ebc02aada3b52d49d0e0f4279d (patch)
tree39f91fd166430a08509930faa6400b1eb902d3bd /dev-vcs
parentgames-strategy/spaz: Stop using games.eclass (diff)
downloadgentoo-fa8312f5798174ebc02aada3b52d49d0e0f4279d.tar.gz
gentoo-fa8312f5798174ebc02aada3b52d49d0e0f4279d.tar.bz2
gentoo-fa8312f5798174ebc02aada3b52d49d0e0f4279d.zip
dev-vcs/git-flow: Version bump 1.12.3
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-flow/Manifest1
-rw-r--r--dev-vcs/git-flow/git-flow-1.12.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-vcs/git-flow/Manifest b/dev-vcs/git-flow/Manifest
index 5060cafa58bb..a20cbb830812 100644
--- a/dev-vcs/git-flow/Manifest
+++ b/dev-vcs/git-flow/Manifest
@@ -1,2 +1,3 @@
DIST git-flow-1.11.0.tar.gz 64077 BLAKE2B 7761ed8020039b2fe9fad23664c5e8d0ad754033e80b3cf402fae5e72331a79ac548f8676f9e8c5d6fe5d7032a5c25770563300d7be81834c3d47869a374ee6b SHA512 3659f876febbec10457ba7ba1ecbaeb7f29b11cc8caf94042f54b8f8e2265d2bb31cbcdf7dfafae9c5d04e0ca57adddfa67f9e67df4a5dcf0bc412f1216a3c07
+DIST git-flow-1.12.3.tar.gz 66173 BLAKE2B c6045fda9df8e305ccde8fac844614c840c5361f41848af6bf3394f64ffbbc5b03c20ed966960667d9aba76b0ed105f4caa2a5c0d5eab02a24720bff7b0aea48 SHA512 807cd36de7f5c9b4a7b28101de5ea8cfcbf528ff76578e4914c788b8098c7d3d91f8c19a3274e124ee7f7b4bdb6efdc5de2b74e09f374b71ae685beaa86e3e5a
DIST git-flow-completion-0.6.0.tar.gz 7823 BLAKE2B 24dedfc0cddb5acfa57333895533f5c882a0c85db6e08539ff5c33f984eec40cb06da6d5f0ba812348c9cbf226080875de0269b295791ee5d4c8b2732a1ea1b2 SHA512 1082ad47938ec78045f4cbd12340a82960ba3de204c21a95e1166cb0b86e96dbbc3e5fc8af1945c951d5edd43b4026021761e8377795acbb87af3c1e391cb256
diff --git a/dev-vcs/git-flow/git-flow-1.12.3.ebuild b/dev-vcs/git-flow/git-flow-1.12.3.ebuild
new file mode 100644
index 000000000000..0e539df2e29c
--- /dev/null
+++ b/dev-vcs/git-flow/git-flow-1.12.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-/}-avh"
+COMP_PN="${PN}-completion"
+COMP_PV="0.6.0"
+COMP_P="${COMP_PN}-${COMP_PV}"
+inherit bash-completion-r1
+
+DESCRIPTION="Git extensions to provide high-level repository operations"
+HOMEPAGE="https://github.com/petervanderdoes/gitflow-avh"
+SRC_URI="https://github.com/petervanderdoes/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/petervanderdoes/${COMP_PN}/archive/${COMP_PV}.tar.gz -> ${COMP_P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-vcs/git"
+
+DOCS=( AUTHORS CHANGELOG.md README.md )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ default
+ sed -i "s/doc\/gitflow/doc\/${P}/" Makefile || die "fixing doc path failed"
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ emake prefix="${D}/usr" install
+ einstalldocs
+ newbashcomp "${WORKDIR}/${COMP_P}/${COMP_PN}.bash" ${PN}
+}