summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2018-11-11 13:45:59 +0000
committerYixun Lan <dlan@gentoo.org>2018-11-11 13:47:25 +0000
commitfdb7062cce72c84b49967509651cf77da2d441f7 (patch)
tree6c39f6efa283a4ab130e3c630065cdd1419ee1a2 /dev-vcs
parentdev-python/pudb: bump to 2018.1 (diff)
downloadgentoo-fdb7062cce72c84b49967509651cf77da2d441f7.tar.gz
gentoo-fdb7062cce72c84b49967509651cf77da2d441f7.tar.bz2
gentoo-fdb7062cce72c84b49967509651cf77da2d441f7.zip
dev-vcs/stgit: version bump, 0.19
bump to 0.19, EAPI=7, python3 support Closes: https://bugs.gentoo.org/670554 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/stgit/Manifest1
-rw-r--r--dev-vcs/stgit/stgit-0.19.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
index 2a5be60b75c6..319123b5f284 100644
--- a/dev-vcs/stgit/Manifest
+++ b/dev-vcs/stgit/Manifest
@@ -1,3 +1,4 @@
DIST stgit-0.16-missing-patches.tar.gz 1667 BLAKE2B 3aa26305b948c49bde0aec71e9698f9c1822c26e1f15ceba99c4725eaa35eee6a7a5335f0bfe6e43e89be62c304e1eebe2ffdaa0a5b7fdc0da3e13244505abaf SHA512 29d4c3e68121654153b4e5142dd70d818737b09bbc8371d644a36dd9d18afaf78fdda91bc16f953c330bcbae19084384d8bcd216cdfe674df784e33165186db1
DIST stgit-0.16.tar.gz 362687 BLAKE2B 4d6579d39d8a22929d70268ae07bf7c5ac17eae21c615aac0ae8e9adb146aa87a3f7d1b057fd7269175c363ef5057f4ce24f6ef1087f54dfb1165f2800a813cf SHA512 782de3d5855aad4f5d040478745990517ebe2b26dc315a3ed41db95399bb46e075d63a70baa0e3aa2ab1012b59e6ad1f5940a904f296ef09d6bca60f66e417dd
DIST stgit-0.18.tar.gz 235852 BLAKE2B ff35856c1f20a6a611a2faa22ba573b1c33636c9e913322456011c4c5a73c3207ddbd8bfe41cb81b11dffe8db8b89594c1598989ae9fb896cd686594a21d96b2 SHA512 5820cc1a8cdd5183fbe309b4b80568098844ff57934c75a43263b5cfcdac4b64e015abc9ed6a53dd856236d76bd0ebeec31e87561bca0d0d82a6e5ec7a10745f
+DIST stgit-0.19.tar.gz 246256 BLAKE2B ece625a0f78f4a80a9a20b25d0638ee71475029ebd861b28dccc444a70d631e687372031c2dee03faebc8890b8742674d6fd7c2ee1794e8a2d7044721a254847 SHA512 0edad0c600145fc779262ddae4300d4718fd04316face62cb1fb5c01e39cb0824355091863aae8d5b14bee9ebb36ac591e5e0dc9fe343c12a7c781227cac6330
diff --git a/dev-vcs/stgit/stgit-0.19.ebuild b/dev-vcs/stgit/stgit-0.19.ebuild
new file mode 100644
index 000000000000..cba2edd82da2
--- /dev/null
+++ b/dev-vcs/stgit/stgit-0.19.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+UPSTREAM_VER=
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.16-man-linkfix.patch"
+)
+
+pkg_setup() {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+python_prepare_all() {
+ # Upstream's patchset
+ [[ -n ${UPSTREAM_VER} ]] && \
+ eapply "${WORKDIR}"/patches-upstream
+
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ echo "version=\"${PV}\"" > "${S}"/stgit/builtin_version.py
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ # bug 526468
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ doc
+ fi
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ install-doc install-html
+ fi
+
+ distutils-r1_src_install
+
+ newbashcomp stgit-completion.bash 'stg'
+}