summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-02 10:40:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-03 08:48:08 +0200
commit8248d14cd0b28edd2ebefbdd941c3284f15f64dd (patch)
treebc71bbb79dcc55d899e8d798c029deb58344cd72 /eclass/distutils-r1.eclass
parentdev-python/pycairo: Enable py3.12 (diff)
downloadgentoo-8248d14cd0b28edd2ebefbdd941c3284f15f64dd.tar.gz
gentoo-8248d14cd0b28edd2ebefbdd941c3284f15f64dd.tar.bz2
gentoo-8248d14cd0b28edd2ebefbdd941c3284f15f64dd.zip
distutils-r1.eclass: Remove support for old maturin
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass44
1 files changed, 15 insertions, 29 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index f3325d5bd8f4..12ed6e77b969 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -230,7 +230,7 @@ _distutils_set_globals() {
;;
maturin)
bdep+='
- >=dev-util/maturin-0.14.17[${PYTHON_USEDEP}]
+ >=dev-util/maturin-1.0.1[${PYTHON_USEDEP}]
'
;;
no)
@@ -1331,26 +1331,21 @@ distutils_pep517_install() {
local config_settings=
case ${DISTUTILS_USE_PEP517} in
maturin)
- # ebuild's DISTUTILS_ARGS are currently ignored if <1.0.0, ebuilds
- # should set the dependency if used until this can be cleaned up
- # (reminder to cleanup the old MATURIN_PEP517_ARGS block too)
- if has_version -b '>=dev-util/maturin-1.0.0'; then
- # `maturin pep517 build-wheel --help` for options
- local maturin_args=(
- "${DISTUTILS_ARGS[@]}"
- --jobs="$(makeopts_jobs)"
- --skip-auditwheel # see bug #831171
- $(in_iuse debug && usex debug '--profile=dev' '')
- )
+ # `maturin pep517 build-wheel --help` for options
+ local maturin_args=(
+ "${DISTUTILS_ARGS[@]}"
+ --jobs="$(makeopts_jobs)"
+ --skip-auditwheel # see bug #831171
+ $(in_iuse debug && usex debug '--profile=dev' '')
+ )
- config_settings=$(
- "${EPYTHON}" - "${maturin_args[@]}" <<-EOF || die
- import json
- import sys
- print(json.dumps({"build-args": sys.argv[1:]}))
- EOF
- )
- fi
+ config_settings=$(
+ "${EPYTHON}" - "${maturin_args[@]}" <<-EOF || die
+ import json
+ import sys
+ print(json.dumps({"build-args": sys.argv[1:]}))
+ EOF
+ )
;;
meson-python)
local -x NINJAOPTS=$(get_NINJAOPTS)
@@ -1526,15 +1521,6 @@ distutils-r1_python_compile() {
esetup.py build -j "${jobs}" "${@}"
fi
;;
- maturin)
- if has_version -b '<dev-util/maturin-1.0.0'; then
- local -x MATURIN_PEP517_ARGS="
- --jobs=$(makeopts_jobs)
- --skip-auditwheel
- $(in_iuse debug && usex debug --profile=dev '')
- "
- fi
- ;;
no)
return
;;