summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro.dev@gmail.com>2017-09-18 20:31:34 +0900
committerAlexis Ballier <aballier@gentoo.org>2017-10-02 10:56:06 +0200
commit7be601e3c17d1abf9b368818ab7f25f9db156f96 (patch)
tree96014f57bf9dee21b8438752c1e6ef50ad541caf /eclass/freebsd.eclass
parentnet-vpn/openvpn: Stable for HPPA too. (diff)
downloadgentoo-7be601e3c17d1abf9b368818ab7f25f9db156f96.tar.gz
gentoo-7be601e3c17d1abf9b368818ab7f25f9db156f96.tar.bz2
gentoo-7be601e3c17d1abf9b368818ab7f25f9db156f96.zip
eclass/freebsd.eclass: update some comments.
Diffstat (limited to 'eclass/freebsd.eclass')
-rw-r--r--eclass/freebsd.eclass30
1 files changed, 15 insertions, 15 deletions
diff --git a/eclass/freebsd.eclass b/eclass/freebsd.eclass
index 24bab67ce620..64d28f9d483a 100644
--- a/eclass/freebsd.eclass
+++ b/eclass/freebsd.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
#
# @MAINTAINER:
@@ -68,7 +68,7 @@ if [[ ${MY_PV} == *9999* ]]; then
ESVN_PROJECT="freebsd-${BRANCH}"
fi
-# use the original source code.
+# Use the original source code.
if [[ ${MY_PV} != *9999* ]] && version_is_at_least 10.0 ${RV} ; then
DL_PV=${MY_PV/_rc/-RC}
DL_PV=${DL_PV/_beta/-BETA}
@@ -114,7 +114,7 @@ freebsd_get_bmake() {
echo "${bmake}"
}
-# Generates a patch SRC_URI or DISTDIR of upstream.
+# Generates SRC_URI or DISTDIR for the upstream patch.
freebsd_upstream_patches() {
local opt=$1
[[ ${#UPSTREAM_PATCHES[@]} -eq 0 ]] && return 1
@@ -172,8 +172,8 @@ freebsd_src_unpack() {
if [[ ${MY_PV} == *9999* ]]; then
S="${WORKDIR}" subversion_src_unpack
- # When share/mk exists in ${WORKDIR}, it is used on FreeBSD 10.0
- # Removed "${WORKDIR}"/share/mk/*.mk, use to force /usr/share/mk.
+ # When share/mk exists in ${WORKDIR}, BSD's make will try to use it on FreeBSD 10.0 or later.
+ # We should remove "${WORKDIR}"/share/mk/*.mk to use /usr/share/mk{,/system}.
if [[ ${PN} != freebsd-mk-defs ]] ; then
[[ -e "${WORKDIR}"/share/mk ]] && rm -rf "${WORKDIR}"/share/mk/*.mk
fi
@@ -214,7 +214,7 @@ freebsd_src_unpack() {
export RSYMLINK=" -l s"
fi
- # When CC=clang, force use clang-cpp #478810, #595878
+ # If CC=clang, we should use clang-cpp instead of cpp. #478810, #595878
if [[ $(tc-getCC) == *clang* ]] ; then
if type -P clang-cpp > /dev/null ; then
export CPP=clang-cpp
@@ -225,7 +225,7 @@ freebsd_src_unpack() {
fi
fi
- # Add a special CFLAGS required for multilib support.
+ # Add the special CFLAGS required for multilib support.
use amd64-fbsd && export CFLAGS_x86_fbsd="${CFLAGS_x86_fbsd} -DCOMPAT_32BIT -B/usr/lib32 -L/usr/lib32"
}
@@ -235,13 +235,13 @@ freebsd_src_compile() {
if ! use profile ; then
mymakeopts="${mymakeopts} WITHOUT_PROFILE= "
fi
- # Disable debugging info, use FEATURES=splitdebug instead.
+ # Disable the debugging information, use FEATURES=splitdebug instead.
mymakeopts="${mymakeopts} WITHOUT_DEBUG_FILES= "
- # Test does not support yet.
+ # We don't support test yet.
mymakeopts="${mymakeopts} WITHOUT_TESTS= "
- # Force set SRCTOP.
+ # Set the SRCTOP to detect the source directory.
mymakeopts="${mymakeopts} SRCTOP=${WORKDIR} "
- # Set common option.
+ # Set the common settings.
mymakeopts="${mymakeopts} WITHOUT_MANCOMPRESS= WITHOUT_INFOCOMPRESS= "
else
use profile || mymakeopts="${mymakeopts} NO_PROFILE= "
@@ -311,13 +311,13 @@ freebsd_src_install() {
if ! use profile ; then
mymakeopts="${mymakeopts} WITHOUT_PROFILE= "
fi
- # Disable debugging info, use FEATURES=splitdebug instead.
+ # Disable the debugging information, use FEATURES=splitdebug instead.
mymakeopts="${mymakeopts} WITHOUT_DEBUG_FILES= "
- # Test does not support yet.
+ # We don't support test yet.
mymakeopts="${mymakeopts} WITHOUT_TESTS= "
- # Force set SRCTOP.
+ # Set the SRCTOP to detect the source directory.
mymakeopts="${mymakeopts} SRCTOP=${WORKDIR} "
- # Set common option.
+ # Set the common settings.
mymakeopts="${mymakeopts} WITHOUT_MANCOMPRESS= WITHOUT_INFOCOMPRESS= "
else
use profile || mymakeopts="${mymakeopts} NO_PROFILE= "