summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2020-03-10 17:44:16 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-10 17:48:13 -0500
commit68746d8443ca152fcc52f1260fd0018ac9a75f4f (patch)
tree0b243c94a7a8961a98b5303f6372da3b37f2f78b /eclass/go-module.eclass
parentwww-apps/blohg: port to python 3 (bug #702226) (diff)
downloadgentoo-68746d8443ca152fcc52f1260fd0018ac9a75f4f.tar.gz
gentoo-68746d8443ca152fcc52f1260fd0018ac9a75f4f.tar.bz2
gentoo-68746d8443ca152fcc52f1260fd0018ac9a75f4f.zip
go-module.eclass: replace GOFLAGS if EGO_VENDOR is being used
We can't repeat the -mod flag, so we need to replace the GOFLAGS if EGO_VENDOR is being used. Closes: https://bugs.gentoo.org/7111640 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'eclass/go-module.eclass')
-rw-r--r--eclass/go-module.eclass4
1 files changed, 3 insertions, 1 deletions
diff --git a/eclass/go-module.eclass b/eclass/go-module.eclass
index c3ad5159bad8..4edffa70e42b 100644
--- a/eclass/go-module.eclass
+++ b/eclass/go-module.eclass
@@ -388,7 +388,9 @@ _go-module_src_unpack_vendor() {
-f "${DISTDIR}/${tarball}" || die
eend
done
- [[ ${#EGO_VENDOR[@]} -gt 0 ]] && GOFLAGS+=" -mod=vendor"
+ # replace GOFLAGS if EGO_VENDOR is being used
+ [[ ${#EGO_VENDOR[@]} -gt 0 ]] &&
+ GOFLAGS="-v -x -mod=vendor"
eqawarn "${P}.ebuild: EGO_VENDOR will be removed in the future."
eqawarn "Please request that the author migrate to EGO_SUM."
}