summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-11-05 04:20:02 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-11-14 04:18:50 +1100
commit03484f8df11f36983d7a00409b0b42f326355806 (patch)
treee76d6724ef373c97dd730e326f3ddf4a4d3ab501 /eclass/kde5.eclass
parentdev-lang/python: Remove more old versions (diff)
downloadgentoo-03484f8df11f36983d7a00409b0b42f326355806.tar.gz
gentoo-03484f8df11f36983d7a00409b0b42f326355806.tar.bz2
gentoo-03484f8df11f36983d7a00409b0b42f326355806.zip
kde5.eclass: introduce "forceoptional" value for KDE_HANDBOOK
Diffstat (limited to 'eclass/kde5.eclass')
-rw-r--r--eclass/kde5.eclass10
1 files changed, 9 insertions, 1 deletions
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index e76a969ff486..7a5d2222eb50 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -80,6 +80,8 @@ fi
# If set to "false", do nothing.
# Otherwise, add "+handbook" to IUSE, add the appropriate dependency, and
# generate and install KDE handbook.
+# If set to "forceoptional", remove a KF5DocTools dependency from the root
+# CMakeLists.txt in addition to the above.
: ${KDE_HANDBOOK:=false}
# @ECLASS-VARIABLE: KDE_DOC_DIR
@@ -418,7 +420,7 @@ kde5_src_prepare() {
popd > /dev/null || die
fi
- if [[ ${KDE_HANDBOOK} = true && -d ${KDE_DOC_DIR} && ${CATEGORY} != kde-apps ]] ; then
+ if [[ ${KDE_HANDBOOK} != false && -d ${KDE_DOC_DIR} && ${CATEGORY} != kde-apps ]] ; then
pushd ${KDE_DOC_DIR} > /dev/null || die
for lang in *; do
if ! has ${lang} ${LINGUAS} ; then
@@ -458,6 +460,12 @@ kde5_src_prepare() {
;;
esac
+ if [[ ${KDE_HANDBOOK} = forceoptional ]] ; then
+ if ! use_if_iuse handbook ; then
+ punt_bogus_dep KF5 DocTools
+ fi
+ fi
+
cmake-utils_src_prepare
}