summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-09 00:04:14 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-09 10:51:42 +0100
commitbccfa10c237cb41debb51092a1f3efdb88a03edf (patch)
tree194625a6f3f7e329c6214e3612888b7c31206177 /eclass/kde5.eclass
parentapp-office/libreoffice: Patch was accepted upstream (diff)
downloadgentoo-bccfa10c237cb41debb51092a1f3efdb88a03edf.tar.gz
gentoo-bccfa10c237cb41debb51092a1f3efdb88a03edf.tar.bz2
gentoo-bccfa10c237cb41debb51092a1f3efdb88a03edf.zip
kde5.eclass: Drop KDE_TESTPATTERN
Never used by many ebuilds, completely unused right now. Closes: https://bugs.gentoo.org/674922 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'eclass/kde5.eclass')
-rw-r--r--eclass/kde5.eclass15
1 files changed, 4 insertions, 11 deletions
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index 79887823556f..5cef3f1033c9 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: kde5.eclass
@@ -119,13 +119,6 @@ if [[ ${CATEGORY} = kde-frameworks ]]; then
fi
: ${KDE_QTHELP:=false}
-# @ECLASS-VARIABLE: KDE_TESTPATTERN
-# @DESCRIPTION:
-# DANGER: Only touch it if you know what you are doing.
-# By default, matches autotest(s), unittest(s) and test(s) pattern inside
-# cmake add_subdirectory calls.
-: ${KDE_TESTPATTERN:="\(auto|unit\)\?tests\?"}
-
# @ECLASS-VARIABLE: KDE_TEST
# @DESCRIPTION:
# If set to "false", do nothing.
@@ -135,7 +128,7 @@ fi
# If set to "forceoptional", remove a Qt5Test dependency and comment test
# subdirs from the root CMakeLists.txt in addition to the above.
# If set to "forceoptional-recursive", remove Qt5Test dependencies and make
-# test subdirs according to KDE_TESTPATTERN from *any* CMakeLists.txt in ${S}
+# autotest(s), unittest(s) and test(s) subdirs from *any* CMakeLists.txt in ${S}
# and below conditional on BUILD_TESTING. This is always meant as a short-term
# fix and creates ${T}/${P}-tests-optional.patch to refine and submit upstream.
if [[ ${CATEGORY} = kde-frameworks ]]; then
@@ -574,12 +567,12 @@ kde5_src_prepare() {
local f pf="${T}/${P}"-tests-optional.patch
touch ${pf} || die "Failed to touch patch file"
for f in $(find . -type f -name "CMakeLists.txt" -exec \
- grep -l "^\s*add_subdirectory\s*\(\s*.*${KDE_TESTPATTERN}\s*)\s*\)" {} \;); do
+ grep -l "^\s*add_subdirectory\s*\(\s*.*\(auto|unit\)\?tests\?\s*)\s*\)" {} \;); do
cp ${f} ${f}.old || die "Failed to prepare patch origfile"
pushd ${f%/*} > /dev/null || die
punt_bogus_dep Qt5 Test
sed -i CMakeLists.txt -e \
- "/^#/! s/add_subdirectory\s*\(\s*.*${KDE_TESTPATTERN}\s*)\s*\)/if(BUILD_TESTING)\n&\nendif()/" \
+ "/^#/! s/add_subdirectory\s*\(\s*.*\(auto|unit\)\?tests\?\s*)\s*\)/if(BUILD_TESTING)\n&\nendif()/" \
|| die
popd > /dev/null || die
diff -Naur ${f}.old ${f} 1>>${pf}