summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-09-18 10:49:58 -0400
committerBrian Evans <grknight@gentoo.org>2015-09-18 10:49:58 -0400
commit2d00da0c3ecc1d4beba6205dd869a4897ffccc10 (patch)
treed356142a537e377f0c06fd5f3180bcf8c7593212 /eclass/mysql-cmake.eclass
parentnet-libs/rb_libtorrent: Fix USE=examples build. Bug #550252 (diff)
downloadgentoo-2d00da0c3ecc1d4beba6205dd869a4897ffccc10.tar.gz
gentoo-2d00da0c3ecc1d4beba6205dd869a4897ffccc10.tar.bz2
gentoo-2d00da0c3ecc1d4beba6205dd869a4897ffccc10.zip
Update mysql eclasses with code to support new dev-db/percona-server
This was accidentially forgotten and generated bugs 560730 and 560734 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'eclass/mysql-cmake.eclass')
-rw-r--r--eclass/mysql-cmake.eclass30
1 files changed, 25 insertions, 5 deletions
diff --git a/eclass/mysql-cmake.eclass b/eclass/mysql-cmake.eclass
index 4354f22ebc78..0f0f5b448fd8 100644
--- a/eclass/mysql-cmake.eclass
+++ b/eclass/mysql-cmake.eclass
@@ -249,8 +249,15 @@ configure_cmake_standard() {
if [[ ${PN} == "percona-server" ]]; then
mycmakeargs+=(
- $(cmake-utils_use_with pam)
+ $(cmake-utils_use_with pam PAM)
)
+ if in_iuse tokudb ; then
+ # TokuDB Backup plugin requires valgrind unconditionally
+ mycmakeargs+=(
+ $(mysql-cmake_use_plugin tokudb TOKUDB)
+ $(usex tokudb-backup-plugin "" -DTOKUDB_BACKUP_DISABLED=1)
+ )
+ fi
fi
if [[ ${PN} == "mysql-cluster" ]]; then
@@ -306,9 +313,20 @@ mysql-cmake_src_prepare() {
if in_iuse tokudb ; then
# Don't build bundled xz-utils
- rm -f "${S}/storage/tokudb/ft-index/cmake_modules/TokuThirdParty.cmake"
- touch "${S}/storage/tokudb/ft-index/cmake_modules/TokuThirdParty.cmake"
- sed -i 's/ build_lzma//' "${S}/storage/tokudb/ft-index/ft/CMakeLists.txt" || die
+ if [[ -d "${S}/storage/tokudb/ft-index" ]] ; then
+ rm -f "${S}/storage/tokudb/ft-index/cmake_modules/TokuThirdParty.cmake" || die
+ touch "${S}/storage/tokudb/ft-index/cmake_modules/TokuThirdParty.cmake" || die
+ sed -i 's/ build_lzma//' "${S}/storage/tokudb/ft-index/ft/CMakeLists.txt" || die
+ elif [[ -d "${S}/storage/tokudb/PerconaFT" ]] ; then
+ rm "${S}/storage/tokudb/PerconaFT/cmake_modules/TokuThirdParty.cmake" || die
+ touch "${S}/storage/tokudb/PerconaFT/cmake_modules/TokuThirdParty.cmake" || die
+ sed -i -e 's/ build_lzma//' -e 's/ build_snappy//' "${S}/storage/tokudb/PerconaFT/ft/CMakeLists.txt" || die
+ sed -i -e 's/add_dependencies\(tokuportability_static_conv build_jemalloc\)//' "${S}/storage/tokudb/PerconaFT/portability/CMakeLists.txt" || die
+ fi
+
+ if [[ -d "${S}/plugin/tokudb-backup-plugin" ]] && ! use tokudb-backup-plugin ; then
+ rm -r "${S}/plugin/tokudb-backup-plugin/Percona-TokuBackup" || die
+ fi
fi
# Remove the bundled groonga if it exists
@@ -399,7 +417,9 @@ mysql-cmake_src_configure() {
CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
fi
# As of 5.7, exceptions and rtti are used!
- if ! mysql_version_is_at_least "5.7" ; then
+ if [[ ${PN} -eq 'percona-server' ]] && mysql_version_is_at_least "5.6.26" ; then
+ CXXFLAGS="${CXXFLAGS} -fno-rtti"
+ elif ! mysql_version_is_at_least "5.7" ; then
CXXFLAGS="${CXXFLAGS} -fno-exceptions -fno-rtti"
fi
export CXXFLAGS