summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-22 19:47:32 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-22 19:47:32 +0100
commit118c8789fe931eb82956408bf4b5553bd3aa5180 (patch)
treebbe364e5efedf4dd27b996abe6a916cf3aec4d50 /eclass/readme.gentoo.eclass
parentreadme.gentoo-r1.eclass: Fix @ECLASS (diff)
downloadgentoo-118c8789fe931eb82956408bf4b5553bd3aa5180.tar.gz
gentoo-118c8789fe931eb82956408bf4b5553bd3aa5180.tar.bz2
gentoo-118c8789fe931eb82956408bf4b5553bd3aa5180.zip
readme.gentoo.eclass: QA warning for deprecation
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'eclass/readme.gentoo.eclass')
-rw-r--r--eclass/readme.gentoo.eclass1
1 files changed, 1 insertions, 0 deletions
diff --git a/eclass/readme.gentoo.eclass b/eclass/readme.gentoo.eclass
index 0ab9e8957a1..97fe12d4b53 100644
--- a/eclass/readme.gentoo.eclass
+++ b/eclass/readme.gentoo.eclass
@@ -31,6 +31,7 @@ case "${EAPI:-0}" in
# from needing to export another pkg_preinst phase to save has_version
# result. Also relies on EAPI >=4 default src_install phase.
EXPORT_FUNCTIONS src_install pkg_postinst
+ eqawarn "This eclass is DEPRECATED. Please use readme.gentoo-r1 instead."
;;
6)
die "Unsupported EAPI=${EAPI} for ${ECLASS}"