summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /eclass/virtuoso.eclass
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'eclass/virtuoso.eclass')
-rw-r--r--eclass/virtuoso.eclass131
1 files changed, 131 insertions, 0 deletions
diff --git a/eclass/virtuoso.eclass b/eclass/virtuoso.eclass
new file mode 100644
index 000000000000..e0ac542a7c29
--- /dev/null
+++ b/eclass/virtuoso.eclass
@@ -0,0 +1,131 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# @ECLASS: virtuoso.eclass
+# @MAINTAINER:
+# Maciej Mrozowski <reavertm@gentoo.org>
+# Chris Reffett <creffett@gentoo.org>
+#
+# @BLURB: Provides splitting functionality for Virtuoso
+# @DESCRIPTION:
+# This eclass provides common code for splitting Virtuoso OpenSource database
+
+case ${EAPI:-0} in
+ 2|3|4|5) : ;;
+ *) die "EAPI=${EAPI} is not supported" ;;
+esac
+
+inherit autotools multilib eutils
+
+MY_P="virtuoso-opensource-${PV}"
+
+case ${PV} in
+ *9999*)
+ ECVS_SERVER="virtuoso.cvs.sourceforge.net:/cvsroot/virtuoso"
+ ECVS_PROJECT='virtuoso'
+ SRC_URI=""
+ inherit cvs
+ ;;
+ *)
+ # Use this variable to determine distribution method (live or tarball)
+ TARBALL="${MY_P}.tar.gz"
+ SRC_URI="mirror://sourceforge/virtuoso/${TARBALL} mirror://gentoo/VOS-genpatches-${PV}.tar.bz2"
+ ;;
+esac
+
+EXPORT_FUNCTIONS src_prepare src_configure
+
+# Set some defaults
+HOMEPAGE='http://virtuoso.openlinksw.com/wiki/main/Main/'
+LICENSE='GPL-2'
+SLOT='0'
+
+DEPEND='
+ >=sys-devel/libtool-2.2.6a
+'
+RDEPEND=''
+
+S="${WORKDIR}/${MY_P}"
+
+# @FUNCTION: virtuoso_src_prepare
+# @DESCRIPTION:
+# 1. Applies common release patches
+# 2. Applies package-specific patches (from ${FILESDIR}/, PATCHES can be used)
+# 3. Applies user patches from /etc/portage/patches/${CATEGORY}/${PN}/
+# 4. Modifies makefiles for split build. Uses VOS_EXTRACT
+# 5. eautoreconf
+virtuoso_src_prepare() {
+ debug-print-function ${FUNCNAME} "$@"
+
+ EPATCH_SUFFIX='patch' EPATCH_FORCE='yes' epatch
+ pushd "${S}" >/dev/null
+ [[ ${PATCHES[@]} ]] && epatch "${PATCHES[@]}"
+
+ debug-print "$FUNCNAME: applying user patches"
+ epatch_user
+
+
+ # @ECLASS-VARIABLE: VOS_EXTRACT
+ # @DESCRIPTION:
+ # Lists any subdirectories that are required to be extracted
+ # and enabled in Makefile.am's for current package.
+ if [[ -n ${VOS_EXTRACT} ]]; then
+ # Comment out everything
+ find . -name Makefile.am -exec \
+ sed -e '/SUBDIRS\s*=/s/^/# DISABLED /g' -i {} + \
+ || die 'failed to disable subdirs'
+
+ # Uncomment specified
+ local path
+ for path in ${VOS_EXTRACT}; do
+ if [[ -d "${path}" ]]; then
+ # Uncomment leaf
+ if [[ -f "${path}"/Makefile.am ]]; then
+ sed -e '/^# DISABLED \s*SUBDIRS\s*=/s/# DISABLED //g' \
+ -i "${path}"/Makefile.am || die "failed to uncomment leaf in ${path}/Makefile.am"
+ fi
+ # Process remaining path elements
+ while true; do
+ local subdir=`basename "${path}"`
+ path=`dirname "${path}"`
+ if [[ -f "${path}"/Makefile.am ]]; then
+ # Uncomment if necessary
+ sed -e '/^# DISABLED \s*SUBDIRS\s*=/s/.*/SUBDIRS =/g' \
+ -i "${path}"/Makefile.am
+ # Append subdirs if not there already
+ if [[ -z `sed -ne "/SUBDIRS\s*=.*${subdir}\b/p" "${path}"/Makefile.am` ]]; then
+ sed -e "/^SUBDIRS\s*=/s|$| ${subdir}|" \
+ -i "${path}"/Makefile.am || die "failed to append ${subdir}"
+ fi
+ fi
+ [[ "${path}" = . ]] && break
+ done
+ fi
+ done
+ fi
+
+ eautoreconf
+}
+
+# @FUNCTION: virtuoso_src_configure
+# @DESCRIPTION:
+# Runs ./configure with common and user options specified via myconf variable
+virtuoso_src_configure() {
+ debug-print-function ${FUNCNAME} "$@"
+
+ # Override some variables to make tests work
+ if [[ ${PN} != virtuoso-server ]]; then
+ [[ ${EAPI} == 2 ]] && ! use prefix && EPREFIX=
+ export ISQL="${EPREFIX}"/usr/bin/isql-v
+ export SERVER="${EPREFIX}"/usr/bin/virtuoso-t
+ fi
+
+ econf \
+ --with-layout=gentoo \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-shared \
+ --with-pthreads \
+ --without-internal-zlib \
+ ${myconf}
+}