summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-09-04 17:32:45 -0400
committerMike Pagano <mpagano@gentoo.org>2021-09-04 17:32:45 -0400
commit16277f08dca35649e52ec4ee9baf870d34a8ca31 (patch)
tree2e5d47dbff8d4ddb88ce2745291b1eb31d9dfce4 /eclass
parentdev-python/flask: Stabilize 2.0.1 arm, #796053 (diff)
downloadgentoo-16277f08dca35649e52ec4ee9baf870d34a8ca31.tar.gz
gentoo-16277f08dca35649e52ec4ee9baf870d34a8ca31.tar.bz2
gentoo-16277f08dca35649e52ec4ee9baf870d34a8ca31.zip
linux-info.eclass: Properly return when makefile found
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/linux-info.eclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/eclass/linux-info.eclass b/eclass/linux-info.eclass
index 1379b6008b86..48f2ff7fbcbb 100644
--- a/eclass/linux-info.eclass
+++ b/eclass/linux-info.eclass
@@ -988,8 +988,8 @@ linux-info_pkg_setup() {
# Order of checking and valid Makefiles names: GNUMakefile, makefile, Makefile
kernel_get_makefile() {
- [[ -s ${KV_DIR}/GNUMakefile ]] && KERNEL_MAKEFILE="${KV_DIR}/GNUMakefile"
- [[ -s ${KV_DIR}/makefile ]] && KERNEL_MAKEFILE="${KV_DIR}/makefile"
- [[ -s ${KV_DIR}/Makefile ]] && KERNEL_MAKEFILE="${KV_DIR}/Makefile"
+ [[ -s ${KV_DIR}/GNUMakefile ]] && KERNEL_MAKEFILE="${KV_DIR}/GNUMakefile" && return
+ [[ -s ${KV_DIR}/makefile ]] && KERNEL_MAKEFILE="${KV_DIR}/makefile" && return
+ [[ -s ${KV_DIR}/Makefile ]] && KERNEL_MAKEFILE="${KV_DIR}/Makefile" && return
}