summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-27 13:22:01 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-08 06:40:20 +0100
commit396a5939bfd6cfabca6356811b7e5e04aa4737e4 (patch)
tree0e31076a6613a6b4fb442c01042e2cf219d457ec /eclass
parentapp-admin/awscli: Bump to 1.32.58 (diff)
downloadgentoo-396a5939bfd6cfabca6356811b7e5e04aa4737e4.tar.gz
gentoo-396a5939bfd6cfabca6356811b7e5e04aa4737e4.tar.bz2
gentoo-396a5939bfd6cfabca6356811b7e5e04aa4737e4.zip
distutils-r1.eclass: Remove -Werror... hack (now in cython)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils-r1.eclass5
1 files changed, 0 insertions, 5 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index c0d1992ccce0..fb0c2dfaa693 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1813,11 +1813,6 @@ distutils-r1_run_phase() {
tc-export AR CC CPP CXX
if [[ ${DISTUTILS_EXT} ]]; then
- if [[ ${BDEPEND} == *dev-python/cython* ]] ; then
- # Workaround for https://github.com/cython/cython/issues/2747 (bug #918983)
- local -x CFLAGS="${CFLAGS} $(test-flags-CC -Wno-error=incompatible-pointer-types)"
- fi
-
local -x CPPFLAGS="${CPPFLAGS} $(usex debug '-UNDEBUG' '-DNDEBUG')"
# always generate .c files from .pyx files to ensure we get latest
# bug fixes from Cython (this works only when setup.py is using