summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-11-25 15:53:58 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-11-27 03:14:01 +1100
commit4ab18c0eb95f77f908684abe6e9b9a5a02cea66b (patch)
tree331460da2ddafd0dd3224cac55d350bc70e9c380 /eclass
parentkde5.eclass: Add KDE_SUBSLOT (diff)
downloadgentoo-4ab18c0eb95f77f908684abe6e9b9a5a02cea66b.tar.gz
gentoo-4ab18c0eb95f77f908684abe6e9b9a5a02cea66b.tar.bz2
gentoo-4ab18c0eb95f77f908684abe6e9b9a5a02cea66b.zip
kde5.eclass: Fix install with L10N=""
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde5.eclass16
1 files changed, 10 insertions, 6 deletions
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index a6fdfa404f1c..53b5eb4d832f 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -500,13 +500,17 @@ kde5_src_prepare() {
rm -r kde-l10n-sr-${PV} || die "Failed to remove sr parent lingua"
fi
- # add all l10n directories to cmake
cat <<-EOF > CMakeLists.txt || die
-project(${PN})
-cmake_minimum_required(VERSION 2.8.12)
-$(printf "add_subdirectory( %s )\n" \
- `find . -mindepth 1 -maxdepth 1 -type d | sed -e "s:^\./::"`)
-EOF
+ project(${PN})
+ cmake_minimum_required(VERSION 2.8.12)
+ EOF
+ # add all l10n directories to cmake
+ if [[ -n ${A} ]]; then
+ cat <<-EOF >> CMakeLists.txt || die
+ $(printf "add_subdirectory( %s )\n" \
+ `find . -mindepth 1 -maxdepth 1 -type d | sed -e "s:^\./::"`)
+ EOF
+ fi
# for KF5: drop KDE4-based part; for KDE4: drop KF5-based part
case ${l10npart} in