summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-09-11 21:39:45 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-09-14 19:56:01 +0200
commit8ac9ef8e3bbb52eb6dbcb15b2660dc58cc3d373c (patch)
tree4932d25e37778653e57db06b5df68c12ee1b250e /eclass
parentpython-utils-r1.eclass: add and use _python_check_EPYTHON (diff)
downloadgentoo-8ac9ef8e3bbb52eb6dbcb15b2660dc58cc3d373c.tar.gz
gentoo-8ac9ef8e3bbb52eb6dbcb15b2660dc58cc3d373c.tar.bz2
gentoo-8ac9ef8e3bbb52eb6dbcb15b2660dc58cc3d373c.zip
distutils-r1.eclass: use _python_check_EPYTHON
Replace the existing EPYTHON check with _python_check_EPYTHON and use _python_check_EPYTHON in a few additional places. Signed-off-by: Florian Schmaus <flow@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/21610
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils-r1.eclass8
1 files changed, 7 insertions, 1 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 786f59636638..1326809a8bc1 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -460,7 +460,7 @@ distutils_enable_tests() {
esetup.py() {
debug-print-function ${FUNCNAME} "${@}"
- [[ -n ${EPYTHON} ]] || die "EPYTHON unset, invalid call context"
+ _python_check_EPYTHON
[[ ${BUILD_DIR} ]] && _distutils-r1_create_setup_cfg
@@ -743,6 +743,8 @@ _distutils-r1_copy_egg_info() {
distutils-r1_python_compile() {
debug-print-function ${FUNCNAME} "${@}"
+ _python_check_EPYTHON
+
_distutils-r1_copy_egg_info
# distutils is parallel-capable since py3.5
@@ -821,6 +823,8 @@ distutils-r1_python_test() {
die "${FUNCNAME} can be only used after calling distutils_enable_tests"
fi
+ _python_check_EPYTHON
+
if [[ ${_DISTUTILS_TEST_INSTALL} ]]; then
distutils_install_for_testing
fi
@@ -860,6 +864,8 @@ distutils-r1_python_test() {
distutils-r1_python_install() {
debug-print-function ${FUNCNAME} "${@}"
+ _python_check_EPYTHON
+
local root=${D%/}/_${EPYTHON}
[[ ${DISTUTILS_SINGLE_IMPL} ]] && root=${D%/}