summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-03-02 02:40:00 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-13 04:00:29 +1100
commit96f7e63620ae1c821f48759e3c6b253f01d9170f (patch)
tree88c60cdac1d3e62d2ac733afd66380e28c8b26ff /eclass
parentkde5.eclass: Convert to add_qt_dep (diff)
downloadgentoo-96f7e63620ae1c821f48759e3c6b253f01d9170f.tar.gz
gentoo-96f7e63620ae1c821f48759e3c6b253f01d9170f.tar.bz2
gentoo-96f7e63620ae1c821f48759e3c6b253f01d9170f.zip
kde5.eclass: Don't delete po/*.po files, only when not in LINGUAS
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde5.eclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index fd83a7109cb9..9356f3921f25 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -387,13 +387,13 @@ kde5_src_prepare() {
if [[ -d po ]] ; then
pushd po > /dev/null || die
for lang in *; do
- if ! has ${lang} ${LINGUAS} ; then
- if [[ ${lang} != CMakeLists.txt ]] ; then
- rm -rf ${lang}
- fi
+ if [[ -d ${lang} ]] && ! has ${lang} ${LINGUAS} ; then
+ rm -r ${lang} || die
if [[ -e CMakeLists.txt ]] ; then
cmake_comment_add_subdirectory ${lang}
fi
+ elif ! has ${lang/.po/} ${LINGUAS} ; then
+ rm ${lang} || die
fi
done
popd > /dev/null || die