summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-04 19:28:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-04 19:44:12 +0100
commitaa7b59dfb5f221348eb495f358a7b953839e3bf3 (patch)
treeaa8609e9123f9f47a59cfcb203f372deb015a4c1 /eclass
parentdistutils-r1.eclass: Update addpredict list (diff)
downloadgentoo-aa7b59dfb5f221348eb495f358a7b953839e3bf3.tar.gz
gentoo-aa7b59dfb5f221348eb495f358a7b953839e3bf3.tar.bz2
gentoo-aa7b59dfb5f221348eb495f358a7b953839e3bf3.zip
distutils-r1.eclass: Remove obsolete conditions
Now that Python < 3.7 is not supported, apply --jobs unconditionally. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils-r1.eclass19
1 files changed, 5 insertions, 14 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 6dd4d51fafd7..d5bb0df4d927 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -780,23 +780,14 @@ distutils-r1_python_compile() {
_distutils-r1_copy_egg_info
- local build_args=()
# distutils is parallel-capable since py3.5
- # to avoid breaking stable ebuilds, enable it only if either:
- # a. we're dealing with EAPI 7
- # b. we're dealing with Python 3.7 or PyPy3
- if python_is_python3 && [[ ${EPYTHON} != python3.4 ]]; then
- if [[ ${EAPI} != [56] || ${EPYTHON} != python3.[56] ]]; then
- local jobs=$(makeopts_jobs "${MAKEOPTS}" INF)
- if [[ ${jobs} == INF ]]; then
- local nproc=$(get_nproc)
- jobs=$(( nproc + 1 ))
- fi
- build_args+=( -j "${jobs}" )
- fi
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" INF)
+ if [[ ${jobs} == INF ]]; then
+ local nproc=$(get_nproc)
+ jobs=$(( nproc + 1 ))
fi
- esetup.py build "${build_args[@]}" "${@}"
+ esetup.py build -j "${jobs}" "${@}"
}
# @FUNCTION: _distutils-r1_wrap_scripts