summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-15 17:14:11 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-20 08:44:03 +0100
commitb2072f61da934b050d8858b30017206a7a464e28 (patch)
tree460c00391021777c55cb3449d521221890bfca2b /eclass
parentdev-tcltk/tktray: MissingTestRestrict (diff)
downloadgentoo-b2072f61da934b050d8858b30017206a7a464e28.tar.gz
gentoo-b2072f61da934b050d8858b30017206a7a464e28.tar.bz2
gentoo-b2072f61da934b050d8858b30017206a7a464e28.zip
distutils-r1.eclass: distutils_enable_tests, add 'setup.py' option
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils-r1.eclass6
1 files changed, 6 insertions, 0 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index e2cd076d4148..63e77bf014c1 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -241,6 +241,7 @@ fi
#
# - nose: nosetests (dev-python/nose)
# - pytest: dev-python/pytest
+# - setup.py: setup.py test (no deps included)
# - unittest: for built-in Python unittest module
#
# This function is meant as a helper for common use cases, and it only
@@ -268,6 +269,11 @@ distutils_enable_tests() {
pytest -vv || die "Tests fail with ${EPYTHON}"
}
;;
+ setup.py)
+ python_test() {
+ esetup.py test --verbose
+ }
+ ;;
unittest)
python_test() {
"${EPYTHON}" -m unittest discover -v ||