summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-23 10:29:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-31 01:06:34 +0100
commite46b7fd568352311ab6b03a7cc38b891ee561e36 (patch)
tree25caed5e7a6c0d15b9162ba9dfd47834662f6281 /eclass
parentpython-utils-r1.eclass: Disable py2.7, except for p-any-r1 (diff)
downloadgentoo-e46b7fd568352311ab6b03a7cc38b891ee561e36.tar.gz
gentoo-e46b7fd568352311ab6b03a7cc38b891ee561e36.tar.bz2
gentoo-e46b7fd568352311ab6b03a7cc38b891ee561e36.zip
distutils-r1.eclass: Switch dift default to --via-root
Switch the default distutils_install_for_testing behavior to --via-root (from legacy --via-home). The old versions of setuptools where --via-home worked are gone, and testing has so far proven that --via-root in the worst case leaves package as broken as before. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils-r1.eclass12
1 files changed, 6 insertions, 6 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index c5c954f49250..07ded8516fdc 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -550,11 +550,11 @@ esetup.py() {
# For most of the packages, tests built in BUILD_DIR are good enough.
#
# The function supports two install modes. The current default is
-# the legacy --via-home mode. However, it has problems with newer
-# versions of setuptools (50.3.0+). The --via-root mode generally
-# works for these packages, and it will probably become the default
-# in the future, once we test all affected packages. Please note
-# that proper testing sometimes requires unmerging the package first.
+# --via-root mode. Previously, the function defaulted to --via-home
+# mode but it has been broken by new versions of setuptools (50.3.0+).
+# If you find that --via-root does not work but --via-home does, please
+# file a bug to let us know. Please note that proper testing sometimes
+# requires unmerging the package first.
distutils_install_for_testing() {
debug-print-function ${FUNCNAME} "${@}"
@@ -575,7 +575,7 @@ distutils_install_for_testing() {
PATH=${bindir}:${PATH}
PYTHONPATH=${libdir}:${PYTHONPATH}
- local install_method=home
+ local install_method=root
case ${1} in
--via-home)
install_method=home