summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-03-08 21:33:03 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-03-08 23:49:55 +0100
commited2ace908b4d5dc23d0f3b873f6d5df867f513d5 (patch)
treeeaa535f0aec89e7b9aff99b64643b37d30d7dd5d /eclass
parentmozconfig-v6.60.eclass: adjust media-libs/libvpx blocker (diff)
downloadgentoo-ed2ace908b4d5dc23d0f3b873f6d5df867f513d5.tar.gz
gentoo-ed2ace908b4d5dc23d0f3b873f6d5df867f513d5.tar.bz2
gentoo-ed2ace908b4d5dc23d0f3b873f6d5df867f513d5.zip
mozcoreconf-v6.eclass: add still required Python 2.7 dependency
In commit 9d973365a74e58731b62caae87d4ad521c90d947 and af9298355290622e1ab2ec5253550e6b8196722a Python 3 support was added and PYTHON_COMPAT was moved from eclass to ebuild as requested by QA. However, Python 2 dependency, which is still required, was lost. This commit will bring back Python 2 dependency. Note that we use python-any-r1_pkg_setup in moz_pkgsetup to initialize Python 3 via PYTHON_COMPAT but we will switch back to Python 2 manually using python_export later. Closes: https://bugs.gentoo.org/679582 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/mozcoreconf-v6.eclass1
1 files changed, 1 insertions, 0 deletions
diff --git a/eclass/mozcoreconf-v6.eclass b/eclass/mozcoreconf-v6.eclass
index 862d632cd99..945b95c31b3 100644
--- a/eclass/mozcoreconf-v6.eclass
+++ b/eclass/mozcoreconf-v6.eclass
@@ -21,6 +21,7 @@ inherit multilib toolchain-funcs flag-o-matic python-any-r1 versionator
IUSE="${IUSE} custom-cflags custom-optimization"
DEPEND="virtual/pkgconfig
+ dev-lang/python:2.7[ncurses,sqlite,ssl,threads(+)]
${PYTHON_DEPS}"
# @FUNCTION: mozconfig_annotate