summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-07-31 19:51:16 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-31 21:42:07 +0100
commitf7bc577cc6dce44e3684d4106853efe5d3f74814 (patch)
tree659ae413866202ef5500f9a36645e2a14c3f65fc /eclass
parenttoolchain.eclass: drop tweak for pythondir for gcc-{4.5..4.7} (diff)
downloadgentoo-f7bc577cc6dce44e3684d4106853efe5d3f74814.tar.gz
gentoo-f7bc577cc6dce44e3684d4106853efe5d3f74814.tar.bz2
gentoo-f7bc577cc6dce44e3684d4106853efe5d3f74814.zip
toolchain.eclass: drop fixheadtails.eclass use for <gcc-4.3
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/toolchain.eclass11
1 files changed, 1 insertions, 10 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 0848fb18e356..b205aeccb5cf 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -7,7 +7,7 @@
DESCRIPTION="The GNU Compiler Collection"
HOMEPAGE="https://gcc.gnu.org/"
-inherit eutils fixheadtails flag-o-matic gnuconfig libtool multilib pax-utils toolchain-funcs prefix
+inherit eutils flag-o-matic gnuconfig libtool multilib pax-utils toolchain-funcs prefix
tc_is_live() {
[[ ${PV} == *9999* ]]
@@ -471,15 +471,6 @@ toolchain_src_prepare() {
find "${S}" -name Makefile.in \
-exec sed -i '/^pkgconfigdir/s:=.*:=$(toolexeclibdir)/pkgconfig:' {} +
- # No idea when this first started being fixed, but let's go with 4.3.x for now
- if ! tc_version_is_at_least 4.3 ; then
- fix_files=""
- for x in contrib/test_summary libstdc++-v3/scripts/check_survey.in ; do
- [[ -e ${x} ]] && fix_files="${fix_files} ${x}"
- done
- ht_fix_file ${fix_files} */configure *.sh */Makefile.in
- fi
-
setup_multilib_osdirnames
gcc_version_patch